Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 14 sur 14
  1. #1
    Invité de passage
    Inscrit en
    avril 2012
    Messages
    11
    Détails du profil
    Informations forums :
    Inscription : avril 2012
    Messages : 11
    Points : 0
    Points
    0

    Par défaut Connexion client Linux

    Bonjour,

    Je galère depuis deux jours à trouver une solution et je perd un peu espoir. Je suis en train de créer une application web qui devra se connecter à un ASE qui est sous Windows.

    Mon problème est que le client est linux et configurer ODBC est un parcours du combattant...

    Quelqu'un aurait-il déjà configuré un client pour se connecter à un ASE ?

    Cordialement,

    piR.R

  2. #2
    Membre du Club
    Inscrit en
    septembre 2007
    Messages
    39
    Détails du profil
    Informations forums :
    Inscription : septembre 2007
    Messages : 39
    Points : 42
    Points
    42

    Par défaut

    Salut,

    Pas d'experience récente avec ODBC sous Unix, mais j'avais de bon souvenirs du driver DataDirect (utilisé avec Informatica).
    Quel est ton problème ? Et pourquoi absolument ODBC ? Tu parles d'une appli web, quel langage utilises-tu ?

  3. #3
    Invité de passage
    Inscrit en
    avril 2012
    Messages
    11
    Détails du profil
    Informations forums :
    Inscription : avril 2012
    Messages : 11
    Points : 0
    Points
    0

    Par défaut

    Salut,

    En gros jusqu'à maintenant, la personne utilisait infomaker qui permettait de générer des rapports d'informations sur la base. Et il se connectait donc à la base depuis des postes windows avec odbc.

    C'est pour ça que je me suis mis en tête d'utiliser odbc... Après s'il est possible facilement de se connecter directement ça ne me pose pas de soucis !

    Mon appli web est en php.
    Par contre je précise que je n'ai pas réellement moyen d'intervenir sur la configuration du serveur Sybase ni sur la base (c'est un prestataire qui doit s'en occuper)...

  4. #4
    Membre du Club
    Inscrit en
    septembre 2007
    Messages
    39
    Détails du profil
    Informations forums :
    Inscription : septembre 2007
    Messages : 39
    Points : 42
    Points
    42

    Par défaut

    Alors, fais simple et interroges la base de donnees avec php
    http://php.net/manual/en/book.sybase.php

  5. #5
    Invité de passage
    Inscrit en
    avril 2012
    Messages
    11
    Détails du profil
    Informations forums :
    Inscription : avril 2012
    Messages : 11
    Points : 0
    Points
    0

    Par défaut

    D'accord merci !

    Mais j'ai toujours le problème d'établissement de la connexion... Comme je suis sur une machine linux et que le serveur et un Microsoft je sais pas trop comment l'effectuer...

    Faut-il que je passe le nom de la machine, l'ip, pour la base de données faut-il le chemin complet ? (du genre D:\\...)

  6. #6
    Rédacteur/Modérateur

    Inscrit en
    janvier 2006
    Messages
    1 307
    Détails du profil
    Informations personnelles :
    Âge : 55

    Informations forums :
    Inscription : janvier 2006
    Messages : 1 307
    Points : 1 607
    Points
    1 607

    Par défaut

    Sous linux il faut créer un nom de serveur logique dans le fichier "interfaces" - le mieux est d'utiliser l'utilitaire dsedit pour cela, et fournir le hostname et le port d'écoute.

    Michael
    Michael Peppler
    Membre de TeamSybase - www.teamsybase.com

    "A successful [software] tool is one that was used to do something undreamed of by its author." -- S. C. Johnson

  7. #7
    Invité de passage
    Inscrit en
    avril 2012
    Messages
    11
    Détails du profil
    Informations forums :
    Inscription : avril 2012
    Messages : 11
    Points : 0
    Points
    0

    Par défaut

    J'ai fait comme tu m'as dit mais toujours rien...

    J'ai mis dans mon hôte l'ip de la machine abrittant le serveur, en port celui que j'avais trouvé sur windows et en nom de serveur celui que j'avais aussi depuis windows (ODBC).

    Le fichier interfaces c'est celui de /etc/network ou il n'a rien à voir ?

  8. #8
    Invité de passage
    Inscrit en
    avril 2012
    Messages
    11
    Détails du profil
    Informations forums :
    Inscription : avril 2012
    Messages : 11
    Points : 0
    Points
    0

    Par défaut

    Quelqu'un aurait une idée ?

    Je rame vraiment pour cette connexion...

  9. #9
    Rédacteur/Modérateur

    Inscrit en
    janvier 2006
    Messages
    1 307
    Détails du profil
    Informations personnelles :
    Âge : 55

    Informations forums :
    Inscription : janvier 2006
    Messages : 1 307
    Points : 1 607
    Points
    1 607

    Par défaut

    Le fichier interfaces est sous $SYBASE/interfaces

    Utilise l'utilitaire dsedit pour le mettre à jour, ce sera plus simple (le format est assez important...)

    Michael
    Michael Peppler
    Membre de TeamSybase - www.teamsybase.com

    "A successful [software] tool is one that was used to do something undreamed of by its author." -- S. C. Johnson

  10. #10
    Invité de passage
    Inscrit en
    avril 2012
    Messages
    11
    Détails du profil
    Informations forums :
    Inscription : avril 2012
    Messages : 11
    Points : 0
    Points
    0

    Par défaut

    D'accord, donc j'ai bien tout configuré avec dsedit, mais je n'ai toujours rien...

    Code :
    Warning: sybase_connect() [FUNCTION.sybase-connect]: Sybase: Unable TO connect IN /opt/lampp/htdocs/test.php ON line 2

  11. #11
    Invité de passage
    Inscrit en
    avril 2012
    Messages
    11
    Détails du profil
    Informations forums :
    Inscription : avril 2012
    Messages : 11
    Points : 0
    Points
    0

    Par défaut

    J'ai regardé mon phpinfo() et j'ai "--with-sybase-ct=/opt/lampp" alors que mon répertoire sybase est /opt/sybase/, est-ce que ça pourrait être ça qui fait tout capoter ?

  12. #12
    Invité de passage
    Inscrit en
    avril 2012
    Messages
    11
    Détails du profil
    Informations forums :
    Inscription : avril 2012
    Messages : 11
    Points : 0
    Points
    0

    Par défaut

    up !

    Personne n'a de solution ?

  13. #13
    Rédacteur/Modérateur
    Avatar de fadace
    Homme Profil pro Fabien Celaia
    Administrateur de base de données
    Inscrit en
    octobre 2002
    Messages
    3 930
    Détails du profil
    Informations personnelles :
    Nom : Homme Fabien Celaia
    Âge : 44
    Localisation : Suisse

    Informations professionnelles :
    Activité : Administrateur de base de données
    Secteur : Service public

    Informations forums :
    Inscription : octobre 2002
    Messages : 3 930
    Points : 14 384
    Points
    14 384

    Par défaut

    Pourquoi donc ODBC ?
    Une connexion native devrait faire l'affaire, non ?
    Que la base soit sous Windows ou Linux ne change rien puisque l'on joue via TCP (selon ce que vous avez comme protocole dans votre fichier interface)
    Sr DBA Oracle / Sybase / MS-SQL / MySQL / DB2 / Postgresql / Informix
    Administrateur SAP
    Mes articles

    Attention : pas de réponse technique par MP : pensez aux autres, passez par les forums !

  14. #14
    Rédacteur/Modérateur

    Inscrit en
    janvier 2006
    Messages
    1 307
    Détails du profil
    Informations personnelles :
    Âge : 55

    Informations forums :
    Inscription : janvier 2006
    Messages : 1 307
    Points : 1 607
    Points
    1 607

    Par défaut

    Il faut aussi s'assurer que la variable d'env SYBASE soit bien positionnée.

    Pour apache cela peut ce faire dans /etc/httpd/httpd.conf - je crois que la directive est SetEnv.

    Michael
    Michael Peppler
    Membre de TeamSybase - www.teamsybase.com

    "A successful [software] tool is one that was used to do something undreamed of by its author." -- S. C. Johnson

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •