p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Nouveau Membre du Club
    Homme Profil pro
    Développeur Web
    Inscrit en
    mai 2011
    Messages
    96
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : mai 2011
    Messages : 96
    Points : 25
    Points
    25

    Par défaut Problème CGI2 NOT OK - paiement CIC en ligne

    Bonjour, tout le monde

    Je rencontre un problème avec la mise en oeuvre du module de paiement enligne CIC sur mon site, le problème se situe après que j'effectue le paiement.
    En fait quand j'effectue le paimeent j'ai le message d'erreur suivant :
    CGI2 NOT OK
    pourtant j'ai utiliser le fichier de retour dans le kit fournit par la banque et j'ai rien changé dans le code. Donc si quelqu'un peut m'aider à résoudre ce problème ?

    ci-joint le fichier où il y a le code

    Je vous remercie d'avance
    Bonne soirée
    Fichiers attachés Fichiers attachés

  2. #2
    Nouveau Membre du Club
    Homme Profil pro
    Développeur Web
    Inscrit en
    mai 2011
    Messages
    96
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : mai 2011
    Messages : 96
    Points : 25
    Points
    25

    Par défaut

    Citation Envoyé par victoires Voir le message
    Bonjour, tout le monde

    Je rencontre un problème avec la mise en oeuvre du module de paiement enligne CIC sur mon site, le problème se situe après que j'effectue le paiement.
    En fait quand j'effectue le paimeent j'ai le message d'erreur suivant :
    CGI2 NOT OK
    pourtant j'ai utiliser le fichier de retour dans le kit fournit par la banque et j'ai rien changé dans le code. Donc si quelqu'un peut m'aider à résoudre ce problème ?

    ci-joint le fichier où il y a le code

    Je vous remercie d'avance
    Bonne soirée
    Bonjour,

    J'ai contacté le service technique de la banque et voici la réponse, ils m'ont dis que l'interface de retour n'a pas répondu correctement
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    reponse  : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1  
    et quand j'exécute moi la page traitement.php, j'ai ça comme résultat :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    Trying PHP<=3 old style ! Is it Better ? Pragma: no-cache Content-type: text/plain Version: 1 Document falsifie 0--6496299+++++1.2open++
    je ne comprends pas comment la banque reçoit alors des caractères bizzares  ...

    si quelqu'un peut me proposer une solution ? Merci d'avance

    Bonne journée

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Paiement CIC, CGI2 NOT OK
    Par erehcab dans le forum E-Commerce
    Réponses: 2
    Dernier message: 30/05/2013, 10h00
  2. [SQL2K][TSQL] Problème de NOT EXISTS
    Par Bal1n dans le forum MS SQL-Server
    Réponses: 7
    Dernier message: 15/05/2006, 10h47
  3. [XSL] Problème "Entity not defined"
    Par FreeCake dans le forum XSL & XSLT
    Réponses: 1
    Dernier message: 11/04/2006, 21h36
  4. Problème avec un tableau et saut de ligne
    Par ero-sennin dans le forum Balisage (X)HTML et validation W3C
    Réponses: 6
    Dernier message: 08/03/2006, 18h48
  5. [PHPMyAdmin]Problème avec "Not Null" dans mysql 5
    Par Ryan Sheckler dans le forum Requêtes
    Réponses: 4
    Dernier message: 15/12/2005, 14h45

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo