+ Répondre à la discussion
Affichage des résultats 1 à 2 sur 2
  1. #1
    Membre éclairé
    Homme Profil pro
    Développeur informatique
    Inscrit en
    février 2007
    Messages
    340
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Transports

    Informations forums :
    Inscription : février 2007
    Messages : 340
    Points : 316
    Points
    316

    Par défaut Fonctionnement étrange

    Bonjour,

    J'essaie d'installer PHPUnit via PEAR et j'ai un comportement assez bizarre.
    Je suis sous windows XP SP3, Wamp, PHP 5.2.11

    Voilà ce que je fais :
    D'abord je mets à jour les catalogues de packages
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
     
    C:\wamp\bin\php\php5.2.11>pear update-channels
    Updating channel "components.ez.no"
    Channel "components.ez.no" is up to date
    Updating channel "doc.php.net"
    Channel "doc.php.net" is up to date
    Updating channel "pear.php.net"
    Channel "pear.php.net" is up to date
    Updating channel "pear.phpunit.de"
    Channel "pear.phpunit.de" is up to date
    Updating channel "pear.symfony-project.com"
    Channel "pear.symfony-project.com" is up to date
    Updating channel "pecl.php.net"
    Channel "pecl.php.net" is up to date
    Ensuite je mets à jour pear
    Code :
    1
    2
    3
     
    C:\wamp\bin\php\php5.2.11>pear upgrade PEAR
    pear/PEAR is already installed and is the same as the released version 1.9.4 upgrade failed
    Donc il me dit que je suis déjà dans la dernière version 1.9.4

    Je lance l'installation de phpunit:
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
     
    C:\wamp\bin\php\php5.2.11>pear install -a pear.phpunit.de/PHPUnit
    phpunit/PHPUnit requires PEAR Installer (version >= 1.9.4), installed version is 1.9.0
    phpunit/File_Iterator requires PEAR Installer (version >= 1.9.2), installed version is 1.9.0
    phpunit/Text_Template requires PEAR Installer (version >= 1.9.4), installed version is 1.9.0
    phpunit/PHP_CodeCoverage requires PEAR Installer (version >= 1.9.4), installed version is 1.9.0
    phpunit/PHP_CodeCoverage requires package "phpunit/File_Iterator" (version >= 1.3.0)
    phpunit/PHP_CodeCoverage requires package "phpunit/Text_Template" (version >= 1.1.1)
    phpunit/PHP_CodeCoverage can optionally use PHP extension "xdebug" (version >= 2.0.5)
    phpunit/PHP_Timer requires PEAR Installer (version >= 1.9.2), installed version
    is 1.9.0
    phpunit/PHPUnit_MockObject requires PEAR Installer (version >= 1.9.4), installed version is 1.9.0
    phpunit/PHPUnit_MockObject requires package "phpunit/Text_Template" (version >= 1.1.1)
    phpunit/PHP_Invoker requires PEAR Installer (version >= 1.9.4), installed versio
    n is 1.9.0
    phpunit/PHP_Invoker requires package "phpunit/PHP_Timer" (version >= 1.0.1)
    phpunit/PHP_Invoker requires PHP extension "pcntl"
    phpunit/PHP_TokenStream requires PEAR Installer (version >= 1.9.4), installed version is 1.9.0
    No valid packages found
    install failed
    Et là il me dit que je ne peux rien installer car mon PEAR est en 1.9.0

    Quelqu'un a une idée ?

    Merci !

  2. #2
    Membre éclairé
    Homme Profil pro
    Développeur informatique
    Inscrit en
    février 2007
    Messages
    340
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Transports

    Informations forums :
    Inscription : février 2007
    Messages : 340
    Points : 316
    Points
    316

    Par défaut

    Bon en fait, très simplement, il y avait 2 installations de pear sur mon poste et les variables d'environnement n'était pas bonne.

    Je les ai corrigé et réinstallé PEAR au bon endroit.
    Maintenant je n'arrive pas à accéder au web via PEAR. A chaque fois que je fais une mise à jour ou autre, il m'envoi balader. Quand je veux définir le proxy, ça ne marche pas non plus

    Code :
    1
    2
    C:\wamp\bin\php\php5.2.11>pear config-set http-proxy http://192.168.0.254:80
    config-set (http-proxy, http://192.168.0.254:80, user) failed, channel pear.php.net

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •