+ Répondre à la discussion
Affichage des résultats 1 à 4 sur 4
  1. #1
    Membre expérimenté Avatar de LeGilou
    Profil pro
    Inscrit en
    octobre 2008
    Messages
    488
    Détails du profil
    Informations personnelles :
    Localisation : France, Ille et Vilaine (Bretagne)

    Informations forums :
    Inscription : octobre 2008
    Messages : 488
    Points : 502
    Points
    502

    Par défaut Attributs inconnus dans Eclipse

    Bonjour,

    Certains attributs HTML sont inconnus par Eclipse. Notamment les attributs HTML5 comme autofocus, type='email', ...

    Comment peut-on indiquer à Eclipse l'existence de ces nouveaux attributs, pour éviter qu'il n'indique des warning injustifiés.

    Merci,
    Gilou.

  2. #2
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 290
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 41
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 290
    Points : 16 822
    Points
    16 822

    Par défaut

    Bonjour,

    Quelle version d'Eclipse utilises-tu ?
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Gardons toujours à l'esprit que le forum constitue une base documentaire dont il nous faut prendre soin en l'alimentant soigneusement, par nos questions et nos réponses. Soyons polis, précis (dans le titre et dans le corps des questions), concis, constructifs et faisons de notre mieux pour respecter la langue française et sa grammaire. Merci pour nous (les modérateurs) mais aussi et surtout, merci pour vous.
    Problème solutionné => je vais au bas de la page et je clique sur le bouton (qui suite à mise à jour du forum, a légèrement changé d'aspect).

  3. #3
    Membre expérimenté Avatar de LeGilou
    Profil pro
    Inscrit en
    octobre 2008
    Messages
    488
    Détails du profil
    Informations personnelles :
    Localisation : France, Ille et Vilaine (Bretagne)

    Informations forums :
    Inscription : octobre 2008
    Messages : 488
    Points : 502
    Points
    502

    Par défaut

    Eclipse for PHP Developers
    Build id: 20100617-1415
    Je l'ai téléchargé il y a 15jours.

  4. #4
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 290
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 41
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 290
    Points : 16 822
    Points
    16 822

    Par défaut

    Ca n'indique pas la plate-forme.
    A priori ça doit être Helios ?

    Je ne sais pas s'il est censé être compatible 100% HTML5 mais de toute manière la version Indigo, qui est plus récente et qui donc à plus de chances d'être compatible, n'a pas été packagée pour PHP.

    Sinon, peut-être qu'une mise à jour du plugin WTP (qui est le plugin gérant l'aspect Web d'Eclipse) résout ton problème...
    Essaye de voir dans Help > Install New Software... , en sélectionnant The Eclipse Web Tools Platform (WTP) software repository (que tu devrais en principe pouvoir choisir dans le Work with), puis en vérifiant qu'il n'y a pas de mises à jour à installer comme celles-ci :
    Web Tools Platform (WTP) 3.3.2
    Web Tools Platform (WTP) Patches 3.3.2


    Remarque : Si tu as les mêmes lignes mais avec SDK dedans, ça ne sert à rien de les installer dans ton cas.

    Autre solution, passer par le Eclipse MarketPlace et voir s'il n'y a pas des plugins qui prennent en charge HTML5 particulièrement.

    Personnellement je ne fais pas de HTML5 donc je ne peux pas t'aider davantage.
    Par contre, comme HTML5 n'est encore qu'un draft, il ne faut peut-être pas trop s'attendre à des miracles.
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Gardons toujours à l'esprit que le forum constitue une base documentaire dont il nous faut prendre soin en l'alimentant soigneusement, par nos questions et nos réponses. Soyons polis, précis (dans le titre et dans le corps des questions), concis, constructifs et faisons de notre mieux pour respecter la langue française et sa grammaire. Merci pour nous (les modérateurs) mais aussi et surtout, merci pour vous.
    Problème solutionné => je vais au bas de la page et je clique sur le bouton (qui suite à mise à jour du forum, a légèrement changé d'aspect).

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •