+ Répondre à la discussion
Affichage des résultats 1 à 2 sur 2
  1. #1
    Nouveau Membre du Club
    Homme Profil pro
    Inscrit en
    mars 2012
    Messages
    20
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : mars 2012
    Messages : 20
    Points : 36
    Points
    36

    Par défaut SQL-Server 2K0 et Powershell

    Bonjour à tous, et tout d'abord j'espère que je poste dans la bonne section, si ce n'est pas le cas merci de me déplacer.

    Je suis actuellement en train d'essayer d'éxécuter un fichier .PS1 dans une procédure stockée avec SQL Server 2000.
    Jusque là, rien de bien compliqué, surtout que le script PS n'est pas des plus compliqués en lui même puisqu'il s'agit d'une simple copie d'un fichier venant d'un autre serveur (réseau pardon) (et bien non, c'est le même serveur mais un autre domaine...)sur mon C, avec quelques contrôles (comparatif entre la taille du fichier source et celle de réception, présence du fichier, etc...).
    Quand j'éxécute mon script via powershell_ise.exe ou via l'invite de commande, aucun soucis.
    Quand j'essaye de faire la même chose sous SQL Server (en dehors de toute procédure stockée pour tester), ça s'éxécute plus ou moins correctement, il me retourne qu'il ne trouve pas mon fichier (à copier) :"Impossible de trouver le chemin d'accès".
    Après quelques recherches, j'ai trouvé que le mode d'authentification par défaut d'éxécution d'un script PS via SQL Server est authentification Windows, j'ai essayé également de me connecter sur SQL Server avec l'authentification Windows, négatif (ce n'est donc pas un problème d'identification).
    Ma question étant, qu'est-ce qui change entre l'éxécution de mon script directement via l'invite de commande et via SQL Server 2K0?

  2. #2
    Nouveau Membre du Club
    Homme Profil pro
    Inscrit en
    mars 2012
    Messages
    20
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : mars 2012
    Messages : 20
    Points : 36
    Points
    36

    Par défaut

    Bon, j'ai finit par trouver la solution à mon problème, en fait je n'avais accès à rien d'autre que mon C:, du coup fatalement ça risquait pas de marcher.

    Pour la suite j'ai été voir ici :
    http://www.developpez.net/forums/d67...eur-different/

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •