Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 2 sur 2
  1. #1
    Membre à l'essai
    Homme Profil pro Jean
    Inscrit en
    octobre 2011
    Messages
    22
    Détails du profil
    Informations personnelles :
    Nom : Homme Jean
    Localisation : Canada

    Informations forums :
    Inscription : octobre 2011
    Messages : 22
    Points : 23
    Points
    23

    Par défaut NET USE avec Perl

    Bonjour,

    Voici mon problème :



    Dans une console DOS (cmd) sur windows, la commande suivante crée un lecteur "Q:"
    NET USE Q: \\nom-pc\repertoire

    Toujours dans une console DOS, la commande suivante supprime le lecteur "Q:"
    NET USE Q: /DELETE





    Or, en perl, la ligne suivante crée le lecteur "Q:" (ça fonctionne)
    exec "NET USE Q: \\\\nom-pc\\Public\\Documents";

    Mais, la commande suivante refuse de supprimer le lecteur "Q:" (ça fonctionne pas)
    exec "NET USE Q: //delete";

    J'ai également essayé :
    exec "NET USE Q: /delete";
    exec "NET USE Q: \/delete";
    exec "NET USE Q: \delete";
    exec "NET USE Q: \\delete";

    Rien y fait!

    Quelqu'un a une idée pourquoi?

    Merci bien pour votre aide!

  2. #2
    Membre à l'essai
    Homme Profil pro Jean
    Inscrit en
    octobre 2011
    Messages
    22
    Détails du profil
    Informations personnelles :
    Nom : Homme Jean
    Localisation : Canada

    Informations forums :
    Inscription : octobre 2011
    Messages : 22
    Points : 23
    Points
    23

    Par défaut

    Bonjour,

    J'ai finalement réussi ainsi :

    system "NET USE Q: \\\\Pc\\Public\\Documents";

    system "NET USE Q: /delete";

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •