1. #1
    Invité de passage
    Homme Profil pro
    Inscrit en
    février 2012
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : février 2012
    Messages : 2
    Points : 0
    Points
    0

    Par défaut [PIC 16F887] Erreur de compilation

    Bonjour,

    Je suis encore débutant en programmation mais en règle générale j'arrive à trouver mes erreurs, mais en ce moment je rencontre des problèmes quand je veux charger un programme en C sur un pic 16F887 au moyen d'un pickit3.

    Début du programme :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    #include<pic.h>
    __CONFIG(UNPROTECT & WDTDIS & XT & DEBUGEN & LVPDIS & INTIO );
    Début des problèmes :
    Error [800] proj2batarrie.as; 45. symbole "INTIO" indéfini
    Error [800] proj2batarrie.as; 45. symbole "LVPDIS" indéfini
    Error [800] proj2batarrie.as; 45. symbole "DEBUGEN" indéfini
    Error [800] proj2batarrie.as; 45. symbole "XT" indéfini
    Error [800] proj2batarrie.as; 45. symbole "WDTDIS" indéfini
    Error [800] proj2batarrie.as; 45. symbole "UNPROTECT" indéfini
    Et j'ai le même problème quand j'utilise un CAN, le GODONE ne passe pas. Je voudrais donc savoir d'ou cela peut venir ; j'ai testé le même programme sur un autre PC avec une version différente de MPLAB et ça fonctionne sans problème. J'ulitise MPLAB v8.83 et HI-TECH C v9.83.

  2. #2
    Membre éclairé
    Homme Profil pro
    Enseignant
    Inscrit en
    janvier 2012
    Messages
    190
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Enseignant
    Secteur : Enseignement

    Informations forums :
    Inscription : janvier 2012
    Messages : 190
    Points : 380
    Points
    380

    Par défaut

    salut !

    ça ressemble bien à un header manquant ...

    bon courage !

  3. #3
    Invité de passage
    Homme Profil pro
    Inscrit en
    février 2012
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : février 2012
    Messages : 2
    Points : 0
    Points
    0

    Par défaut

    Ok, merci mais ce header serais plutôt manquant dans le compilateur le logiciel ou peux être que la bibliothèque du pic est éronnée ?

    Dois je tout réinstaller ou ajouter des éléments ?

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo