Bonjour ,

je commence a utiliser Jasper avec websphere pour generer des rapports, mais je suis confronté a un serieux probleme,
j'utilise Websphere version : 5.1.1 et Jasper version : 4.5.0
On m'a suggeré dans le forum d'utliser JDK 1.5. Ce que j'ai fais, mais quant je lance websphere avec le nouveau JDK ( wsappdev -vm /chemin/vers/java1.5/bin/javaw.exe), j'obtiens un message du genre : ne peut pas creer la machine virtuelle java.

SVP, de l'aide.
a la compilation du rapport, j'obtiens une exception:
Code :
1
2
3
4
5
6
7
8
 
Exception occurred during event dispatching:
java.lang.UnsupportedClassVersionError: net/sf/jasperreports/engine/JasperCompileManager (Unsupported major.minor version 48.0)
	at java.lang.ClassLoader.defineClass0(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:703)
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:133)
	at java.net.URLClassLoader.defineClass(URLClassLoader.java:320)
	at java.net.URLClassLoader.access$400(URLClassLoader.java:93)
voici mon bout de code java:
Code :
1
2
3
4
5
6
7
8
9
10
 
try{
	String report = "C:\\Documents and Settings\\My Documents\\report.jrxml";
	JasperReport jr = JasperCompileManager.compileReport(report);
	JasperPrint jp = JasperFillManager.fillReport(jr,null,con);
	JasperViewer.viewReport(jp);
}catch(Exception ex)
{
	System.out.println("-------" + ex);
}