p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Membre Expert
    Homme Profil pro
    Directeur technique
    Inscrit en
    mai 2008
    Messages
    2 162
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Algérie

    Informations professionnelles :
    Activité : Directeur technique
    Secteur : Service public

    Informations forums :
    Inscription : mai 2008
    Messages : 2 162
    Points : 2 210
    Points
    2 210

    Par défaut Petit pépin depuis ce matin !

    Salut !
    ma base de données FB refuse tout utilisateur autre que SYSDBA !! et ce depuis ce matin. aucune modification sur la structure de la base de données n'a été faite, aucun nouvel utilisateur a été ajouter mais bizarrement elle refuse tout les utilisateurs déjà existants et me sort un méchant message d'erreur :
    Attempting to connect to:
    PC-DEM-HADRI:c:\data\BD_EXPLOITATION.FDB

    Connecting... Failed!
    ------------------------------------
    can't format message 13:98 -- message system code -4.
    database C:\DATA\BD_EXPLOITATION.FDB shutdown.

    Attempting to connect to services manager... Passed!

    Disconnecting from database... Passed!
    quelqu'un a-t-il rencontré cette erreur ? quelles solutions préconisez-vous ?

    j'attends vos lumières, merci par avance.
    Bon courage ou Bonne Chance (selon le contexte)

  2. #2
    Expert Confirmé

    Homme Profil pro
    Consultant spécialité Firebird
    Inscrit en
    mai 2002
    Messages
    2 319
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 52
    Localisation : France

    Informations professionnelles :
    Activité : Consultant spécialité Firebird
    Secteur : Conseil

    Informations forums :
    Inscription : mai 2002
    Messages : 2 319
    Points : 3 569
    Points
    3 569

    Par défaut

    c'est écrit dans le message, elle est en mode shutdown
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    database C:\DATA\BD_EXPLOITATION.FDB shutdown.
    cf gfix http://www.firebirdsql.org/file/docu...startstop.html
    Philippe Makowski
    IBPhoenix - Firebird
    Membre de l'April

  3. #3
    Membre Expert
    Homme Profil pro
    Directeur technique
    Inscrit en
    mai 2008
    Messages
    2 162
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Algérie

    Informations professionnelles :
    Activité : Directeur technique
    Secteur : Service public

    Informations forums :
    Inscription : mai 2008
    Messages : 2 162
    Points : 2 210
    Points
    2 210

    Par défaut

    Citation Envoyé par makowski Voir le message
    c'est écrit dans le message, elle est en mode shutdown
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    database C:\DATA\BD_EXPLOITATION.FDB shutdown.
    cf gfix http://www.firebirdsql.org/file/docu...startstop.html

    Salut
    merci maitre.
    Pour le partage, j'ai éteint le serveur (PC) puis redéfinis l'adresse IP de chacun des postes clients sur l'adresse IP du serveur et tout est rentrée dans l'ordre.
    Bon courage ou Bonne Chance (selon le contexte)

  4. #4
    Expert Confirmé
    Avatar de Barbibulle
    Inscrit en
    octobre 2002
    Messages
    1 860
    Détails du profil
    Informations personnelles :
    Âge : 45

    Informations forums :
    Inscription : octobre 2002
    Messages : 1 860
    Points : 2 734
    Points
    2 734

    Par défaut

    Sinon, pour ceux qui veulent la solution :

    La base a été mis en mode 'shutdown' (Pour pouvoir effectuer une restauration ou de la maintenance) Dans cet état on ne peut pas se connecter (sauf SYSDBA).

    Une fois la maintenance effectuée il faut remettre la base en ligne (accessible) (sauf après un restaure il me semble que la base se remet en ligne automatiquement).

    La commande :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    gfix -o[nline] database_name

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Petit pépin avec OnClose
    Par Just-Soft dans le forum Langage
    Réponses: 3
    Dernier message: 15/12/2014, 08h35
  2. [WS 2003] depuis ce matin plus de terminal server ne fonctionne
    Par clavier12AZQSWX dans le forum Windows Serveur
    Réponses: 5
    Dernier message: 02/04/2012, 10h36
  3. http://schemas.xmlsoap.org/ inaccessible depuis ce matin
    Par arnolem dans le forum Services Web
    Réponses: 17
    Dernier message: 31/01/2011, 09h49
  4. Depuis ce matin : Erreur interne C13310
    Par Cazaux-Moutou-Philippe dans le forum Langage
    Réponses: 3
    Dernier message: 05/12/2008, 15h19
  5. Petit pépin avec la propriété Checked dans un TMainMenu
    Par Ithomir dans le forum Composants VCL
    Réponses: 1
    Dernier message: 24/02/2006, 10h00

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo