Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 10 sur 10
  1. #1
    Membre du Club Avatar de Heavy Metal Hero
    Homme Profil pro
    Étudiant
    Inscrit en
    juin 2007
    Messages
    101
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : juin 2007
    Messages : 101
    Points : 60
    Points
    60

    Par défaut Problème de permission chmod a+x

    Bonjour,
    Je suis sous fedora 15 et je dois créer une application en ocaml. Une fois que j'ai compilé, un executable apparait, et impossible de l'executer (pourtant il n' y a pas de bug). Le problème vient des permissions : quand je fais ./badaboum (mon nom de fichier) il affiche bash: badabou : permission non accordée.
    Dans les propriétés il est ouvrable en lecture et en écriture pour mon utilisateur actuel mais pas à l'éxécution.

    quand je fais un chmod +x ou chmod a+x en console, cela n'a aucun effet ! Si je le fais de manière graphique dans la fenetre permission du fichier la croix se décoche automatiquement !

    Je sais pas comment faire !Pourquoi je ne peux pas éxécuter mon propre programme ???

    Merci !

  2. #2
    Responsable Modération

    Avatar de ok.Idriss
    Homme Profil pro Idriss Neumann
    Consultant en SSII et ingénieur CNAM Paris (spécialité SI)
    Inscrit en
    février 2009
    Messages
    5 020
    Détails du profil
    Informations personnelles :
    Nom : Homme Idriss Neumann
    Âge : 23
    Localisation : France, Essonne (Île de France)

    Informations professionnelles :
    Activité : Consultant en SSII et ingénieur CNAM Paris (spécialité SI)
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : février 2009
    Messages : 5 020
    Points : 16 961
    Points
    16 961

    Par défaut

    Bonsoir.

    Donnes nous la sortie de :

    ls -la | grep <nom_executable>
    Dans le bon répertoire ...

    Cordialement,
    Idriss
    mes cours sur DVP | initiation aux bases de données relationnelles | FAQ Linux | FAQ tests
    la programmation Shell | bonnes pratiques Bash | exercices shells scripts & Bash corrigés
    Merci aussi de lire les règles du club

    "Forgiveness does not change the past, but it does enlarge the future." (Paul Boese)
    Traduction approximative : le pardon ne change pas le passé mais élargit l'horizon de l'avenir.

  3. #3
    Membre du Club Avatar de Heavy Metal Hero
    Homme Profil pro
    Étudiant
    Inscrit en
    juin 2007
    Messages
    101
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : juin 2007
    Messages : 101
    Points : 60
    Points
    60

    Par défaut

    Code :
    1
    2
    3
    4
    5
    6
    7
    [quentin@localhost TP7]$ ls -la | grep tp7
    -rw-------. 1 quentin quentin 234890 18 déc.  14:51 tp7
    -rw-------. 1 quentin quentin   1444 18 déc.  14:51 tp7.cmi
    -rw-------. 1 quentin quentin    284 18 déc.  14:51 tp7.cmx
    -rw-------. 1 quentin quentin    530 18 déc.  14:51 tp7.ml
    -rw-------. 1 quentin quentin    189 17 déc.  20:02 tp7.ml~
    -rw-------. 1 quentin quentin   4704 18 déc.  14:51 tp7.o
    On voit bien que le fichier est toujours en lecture écriture. après j'ai fait ça :
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    [quentin@localhost TP7]$ chmod a+x tp7
    [quentin@localhost TP7]$ ls -la | grep tp7
    -rw-------. 1 quentin quentin 234890 18 déc.  14:51 tp7
    -rw-------. 1 quentin quentin   1444 18 déc.  14:51 tp7.cmi
    -rw-------. 1 quentin quentin    284 18 déc.  14:51 tp7.cmx
    -rw-------. 1 quentin quentin    530 18 déc.  14:51 tp7.ml
    -rw-------. 1 quentin quentin    189 17 déc.  20:02 tp7.ml~
    -rw-------. 1 quentin quentin   4704 18 déc.  14:51 tp7.o
    Toujours pas de changement

  4. #4
    Expert Confirmé
    Homme Profil pro
    Inscrit en
    septembre 2006
    Messages
    2 390
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : septembre 2006
    Messages : 2 390
    Points : 2 807
    Points
    2 807

    Par défaut

    Citation Envoyé par Heavy Metal Hero Voir le message
    Bonjour,
    Je suis sous fedora 15 et je dois créer une application en ocaml. Une fois que j'ai compilé, un executable apparait, et impossible de l'executer (pourtant il n' y a pas de bug). Le problème vient des permissions : quand je fais ./badaboum (mon nom de fichier) il affiche bash: badabou : permission non accordée.
    Dans les propriétés il est ouvrable en lecture et en écriture pour mon utilisateur actuel mais pas à l'éxécution.

    quand je fais un chmod +x ou chmod a+x en console, cela n'a aucun effet ! Si je le fais de manière graphique dans la fenetre permission du fichier la croix se décoche automatiquement !

    Je sais pas comment faire !Pourquoi je ne peux pas éxécuter mon propre programme ???

    Merci !
    serait-ce SELinux qui est activé et que votre profil ne permette pas de changer les permissions pour ajouter le bit executable ?

  5. #5
    Expert Confirmé Sénior
    Profil pro
    Inscrit en
    janvier 2011
    Messages
    1 706
    Détails du profil
    Informations personnelles :
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations forums :
    Inscription : janvier 2011
    Messages : 1 706
    Points : 4 859
    Points
    4 859

    Par défaut

    Salut,

    Et avec un chmod -v u+x tp7 ?
    $ man woman
    Il n'y a pas de page de manuel pour woman.

  6. #6
    Expert Confirmé Sénior
    Homme Profil pro Laurent Willems
    MOA? hahaha - MOE? euhh - Chapeau pointu? turlututu!
    Inscrit en
    septembre 2002
    Messages
    3 152
    Détails du profil
    Informations personnelles :
    Nom : Homme Laurent Willems
    Âge : 35
    Localisation : Belgique

    Informations professionnelles :
    Activité : MOA? hahaha - MOE? euhh - Chapeau pointu? turlututu!

    Informations forums :
    Inscription : septembre 2002
    Messages : 3 152
    Points : 5 248
    Points
    5 248

    Par défaut

    Saluteries


    Code :
    1
    2
    -rw-------. 1 quentin quentin 234890 18 déc.  14:51 tp7
    https://fedoraproject.org/wiki/Fedor..._some_files.3F


    Why does ls show a dot (.) or a plus (+) at the end on the file modes for some files?

    Example,


    -rw-r--r--. 1 root root 1626054 Apr 20 15:44 System.map-2.6.29.1-102.fc11.x86_64
    -rw-r--r-- 1 root root 1626169 Apr 24 11:08 System.map-2.6.29.1-111.fc11.x86_64

    It is a new feature introduced in the latest version of coreutils included in Fedora 11. The info page on ls (# info ls) has the answer

    Following the file mode bits is a single character that specifies
    whether an alternate access method such as an access control list
    applies to the file. When the character following the file mode
    bits is a space, there is no alternate access method. When it is
    a printing character, then there is such a method.

    GNU `ls' uses a `.' character to indicate a file with an SELinux
    security context, but no other alternate access method.

    A file with any other combination of alternate access methods is
    marked with a `+' character.
    Alea Jacta Test!

  7. #7
    Membre du Club Avatar de Heavy Metal Hero
    Homme Profil pro
    Étudiant
    Inscrit en
    juin 2007
    Messages
    101
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : juin 2007
    Messages : 101
    Points : 60
    Points
    60

    Par défaut

    Voici ce que j'ai essayé :
    Code :
    1
    2
    3
    4
     [quentin@localhost tp8]$ chmod -v u+x tp8
    le mode de «*tp8*» a été modifié en 0700 (rwx------).
    [quentin@localhost tp8]$ ./tp8+
    bash: ./tp8+: Permission non accordée
    Cette solution change rien apparement, je l'ai même testée en root, même résultat.
    SInon si j'ai bien compris le message de mygale1978, le point indiquerait que mon problème vient de SELinux ? Dnas ce cas là comment désactiver cette sécrité sachant que je pex être en root ?

  8. #8
    Expert Confirmé Sénior
    Homme Profil pro Laurent Willems
    MOA? hahaha - MOE? euhh - Chapeau pointu? turlututu!
    Inscrit en
    septembre 2002
    Messages
    3 152
    Détails du profil
    Informations personnelles :
    Nom : Homme Laurent Willems
    Âge : 35
    Localisation : Belgique

    Informations professionnelles :
    Activité : MOA? hahaha - MOE? euhh - Chapeau pointu? turlututu!

    Informations forums :
    Inscription : septembre 2002
    Messages : 3 152
    Points : 5 248
    Points
    5 248

    Par défaut

    Hello,

    En cherchant un peu sur le net tu trouveras facilement la réponse à ta question.

    http://linuxconfig.org/how-to-disable-selinux
    Alea Jacta Test!

  9. #9
    Membre du Club Avatar de Heavy Metal Hero
    Homme Profil pro
    Étudiant
    Inscrit en
    juin 2007
    Messages
    101
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : juin 2007
    Messages : 101
    Points : 60
    Points
    60

    Par défaut

    J'ai essayé setenforce 0 pour désactiver temporairement le SELinux. Il y avait toujours le même problème, j'ai donc changé le fichier de configuration de SELinux pour mettre la variable SELINUX = disabled.
    J'ai ensuite marqué ça :

    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    [root@localhost tp8]# setenforce 0
    setenforce: SELinux is disabled
    [root@localhost tp8]# chmod -v u+x tp8
    le mode de «*tp8*» a été modifié en 0700 (rwx------).
    [root@localhost tp8]# ls -la |grep tp8
    -rw------- 1 quentin quentin 4749 25 déc.  00:19 tp8
    -rw------- 1 quentin quentin  119 25 déc.  00:18 tp8.c
    [root@localhost tp8]# ./tp8
    bash: ./tp8: Permission non accordée
    [root@localhost tp8]# cat /etc/selinux/config
    # This file controls the state of SELinux on the system.
    # SELINUX= can take one of these three values:
    #	enforcing - SELinux security policy is enforced.
    #	permissive - SELinux prints warnings instead of enforcing.
    #	disabled - SELinux is fully disabled.
    SELINUX=disabled
    # SELINUXTYPE= type of policy in use. Possible values are:
    #	targeted - Only targeted network daemons are protected.
    #	strict - Full SELinux protection.
    SELINUXTYPE=targeted
    [root@localhost tp8]#
    Comme vous le voyez tp8 est toujours interdit à l'éxécution mais il y a néamoins un changement :
    -rw------- 1 quentin quentin 4749 25 déc. 00:19 tp8

    Il n'y a plus de point après rw------- J'imagine donc que mes manip sur SELinux ont marché, le problème doit donc venir d'ailleur. Une idée ?

  10. #10
    Expert Confirmé Sénior
    Homme Profil pro Laurent Willems
    MOA? hahaha - MOE? euhh - Chapeau pointu? turlututu!
    Inscrit en
    septembre 2002
    Messages
    3 152
    Détails du profil
    Informations personnelles :
    Nom : Homme Laurent Willems
    Âge : 35
    Localisation : Belgique

    Informations professionnelles :
    Activité : MOA? hahaha - MOE? euhh - Chapeau pointu? turlututu!

    Informations forums :
    Inscription : septembre 2002
    Messages : 3 152
    Points : 5 248
    Points
    5 248

    Par défaut

    Ok,

    Pour info, si tu modifies la valeur de selinux dans le fichier de configuration. Il te faut redémarrer ta machine.

    Peux-tu donner le chemin complet vers tes repertoires tp?

    Peux-tu également afficher les différent points de montage que tu as sur ton système?

    Alea Jacta Test!

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •