p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Nouveau Membre du Club
    Homme Profil pro
    Développeur Web
    Inscrit en
    mai 2011
    Messages
    72
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Suisse

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : mai 2011
    Messages : 72
    Points : 26
    Points
    26

    Par défaut Répertoire PEAR absent (Wamp)

    Bonjour,

    Je tente depuis quelques heures d'installer PEAR sous wampserver2.1 (Windows7 64bit).

    Seulement voilà j'ai l'impression que la bibliothèque PEAR est totalement absente. Pas de répertoire PEAR dans wamp/bin/php/php5.3.4, pas de go-pear.bat non plus... Au fait je ne trouve rien en rapport avec PEAR dans mon wamp alors que PEAR est censé être installé d'office non?

    J'ai ré installer wamp et toujours rien. Il y t'il un moyen d'ajouter PEAR directement dans wamp? Je ne trouve rien sur le net car à chaque fois il est mis qu'il faut exécuter go-pear.bat et je n'ai pas ce fichier... Quelqu'un peut-il m'aider?

    Merci

  2. #2
    Expert Confirmé Sénior

    Inscrit en
    septembre 2010
    Messages
    7 957
    Détails du profil
    Informations forums :
    Inscription : septembre 2010
    Messages : 7 957
    Points : 10 641
    Points
    10 641

    Par défaut

    t'as été sur le site de PEAR ?

  3. #3
    Nouveau Membre du Club
    Homme Profil pro
    Développeur Web
    Inscrit en
    mai 2011
    Messages
    72
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Suisse

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : mai 2011
    Messages : 72
    Points : 26
    Points
    26

    Par défaut

    Oui mais je ne comprend pas ce qu'il faut télécharger et où l'installer! Quelqu'un à t'il un tuto ou une page expliquant cela?

  4. #4
    Expert Confirmé Sénior

    Inscrit en
    septembre 2010
    Messages
    7 957
    Détails du profil
    Informations forums :
    Inscription : septembre 2010
    Messages : 7 957
    Points : 10 641
    Points
    10 641

    Par défaut

    Citation Envoyé par liryks_6 Voir le message
    Oui mais je ne comprend pas ce qu'il faut télécharger et où l'installer! Quelqu'un à t'il un tuto ou une page expliquant cela?
    euh y'a un topic juste au dessus qui explique tout ça

  5. #5
    Nouveau Membre du Club
    Homme Profil pro
    Développeur Web
    Inscrit en
    mai 2011
    Messages
    72
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Suisse

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : mai 2011
    Messages : 72
    Points : 26
    Points
    26

    Par défaut

    Ah oui, j'étais passé à côté... Excusez moi... Je vais essayer avec ça alors http://php.developpez.com/cours/pear/installation/

    J'espère résoudre mon problème...

    Merci

  6. #6
    Nouveau Membre du Club
    Homme Profil pro
    Développeur Web
    Inscrit en
    mai 2011
    Messages
    72
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Suisse

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : mai 2011
    Messages : 72
    Points : 26
    Points
    26

    Par défaut

    J'ai réalisé le tuto dans son intégralité et cela fonctionne... Maintenant j'aimerai pouvoir installer symfony... Avec le tuto que j'ai réalisé, PEAR est-il complètement installé?
    Si oui, en voulant installer symfony, les commande "pear" ne fonctionne pas chez moi... Avez vous une idée de pourquoi?
    Merci d'avance

  7. #7
    Nouveau Membre du Club
    Homme Profil pro
    Développeur Web
    Inscrit en
    mai 2011
    Messages
    72
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Suisse

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : mai 2011
    Messages : 72
    Points : 26
    Points
    26

    Par défaut PEAR problèmes avec php5.3.4 et wamp

    Bonjour,

    J'aimerai installer symfony sur mon server WAMP en local donc.
    J'ai réalisé ce tuto ->http://php.developpez.com/cours/pear/installation/.
    Et là me vient une question qui pourra peut être vous paraître évidente mais qui ne l'est pas pour moi: PEAR est-il installé après ces manipulations?

    Ensuite j'aimerai utilisé la commande pear dans mon invite de commande. J'ai pour cela modifié ma variable d'environnement PATH en y ajoutant \;c:\wamp\bin\php\php5.3.4\pear ou \;c:\wamp\bin\php\php5.3.4\. J'ai ensuite tenté d'utiliser la commande pear dans mon invite de commande et la j'obtiens le message "pear n'est pas reconnu en tant que commande interne" !

    J'ai testé cette commande de deux manière
    1/ c:\Users\MonNom>pear
    2/ c:\wamp\bin\php\php5.3.4>pear

    Toujours le même résultat... Voilà je suis dans le flou total... Voilà trois jours que je cherche une soluce sur le net mais je ne trouve pas mon bonheur.

    Ma config: Windows 7/Wamp2.1\php5.3.4

    Je vous remercie d'avance.

  8. #8
    Nouveau Membre du Club
    Homme Profil pro
    Développeur Web
    Inscrit en
    mai 2011
    Messages
    72
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Suisse

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : mai 2011
    Messages : 72
    Points : 26
    Points
    26

    Par défaut

    Bref.

    Je ne sais pas si PEAR était installé après ce tuto. Du coup j'ai procédé d'une autre manière.

    J'ai télécharger go-pear.phar que j'ai placé dans mon répertoire wamp/bin/php/php5.3.4.

    Je l'ai ensuite exécuté dans l'invite de commande comme ceci "php -q go-pear.phar".

    J'ai ensuite rencontré un problème de "permission denied" que j'ai résolu grâce à ce topic http://stackoverflow.com/questions/2...r-ini-location!

    En plus de ça j'ai modifié ma variable d'environnement path et le tour est joué.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 0
    Dernier message: 27/06/2012, 14h18
  2. Répertoires, fichiers absents dans localhost
    Par khrysty dans le forum Windows 7
    Réponses: 2
    Dernier message: 22/06/2012, 18h01
  3. Installation de PEAR avec Wamp PHP 5.3.0
    Par ghis33 dans le forum PEAR
    Réponses: 14
    Dernier message: 26/10/2010, 13h21
  4. .htaccess pas présent dans le répertoire www de Wamp
    Par skunkies dans le forum Apache
    Réponses: 3
    Dernier message: 24/11/2009, 17h12

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo