p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Candidat au titre de Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2011
    Messages
    129
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 23
    Localisation : France, Pas de Calais (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : mai 2011
    Messages : 129
    Points : 13
    Points
    13

    Par défaut problème de compatibilité entre PC

    Bonjour,

    Voila j'ai déployé un projet VB6 qui utilise une base ACCESS 97.
    Étant donné que j'utilise des etats etc je n'ai pas utilisé de connection ADO.
    Le pc sur lequel j'ai déployé l'application a Office (et donc access) 2002( ou 2003 je ne sais pas exactement).

    Sur mon PC l'application ne rencontre aucun bug pour ce qui est de supprimer quelque chose (requête delete) ou pour des requêtes pour ouvrir mes Etats.
    Alors que sur le pc où j'ai déployé l'appli j'ai ces "bug" là

    Ma question est : est-ce que c'est un problème de compatibilité Access?
    dois-je mettre mon projet sous Access 2000? et quel référence je dois alors activé dans mon projet?


    PS : de même j'ai réussi à corriger une erreur "invalid use of NULL" en mettant dans ma base : utilisation de NULL interdit : OUI
    et le problème était corrigé sur mon pc mais sur l'autre cela ne marche plus =(

    Merci pour vos conseils =)

  2. #2
    Expert Confirmé Sénior
    Avatar de ThierryAIM
    Homme Profil pro
    Inscrit en
    septembre 2002
    Messages
    3 672
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 52
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Secteur : Industrie

    Informations forums :
    Inscription : septembre 2002
    Messages : 3 672
    Points : 8 406
    Points
    8 406

    Par défaut

    Access 97 se pilote avec DAO 3.51
    Depuis Access 2000, il faut utiliser DAO 3.6

    IL y a de fortes chances que tes problèmes de compatibilité viennent de là

  3. #3
    Candidat au titre de Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2011
    Messages
    129
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 23
    Localisation : France, Pas de Calais (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : mai 2011
    Messages : 129
    Points : 13
    Points
    13

    Par défaut

    D'accord merci,

    D'un point de vu longevité et fiabilité il vaut mieux que je passe mon appli en dao 3.6?
    Car comme c'est pour un stage, mon appli va "voyager" entre divers machines etc... La/les personnes pourront l'utiliser via Access 2000 ET 2002 ou seulement 2000?

  4. #4
    Expert Confirmé Sénior
    Avatar de ThierryAIM
    Homme Profil pro
    Inscrit en
    septembre 2002
    Messages
    3 672
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 52
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Secteur : Industrie

    Informations forums :
    Inscription : septembre 2002
    Messages : 3 672
    Points : 8 406
    Points
    8 406

    Par défaut

    oui, tu devrais passer en 3.6

    Access 2000 à 2003, sans souci

  5. #5
    Candidat au titre de Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2011
    Messages
    129
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 23
    Localisation : France, Pas de Calais (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : mai 2011
    Messages : 129
    Points : 13
    Points
    13

    Par défaut

    Bonsoir,

    Une erreur est apparu sur le PC en question (windows XP) depuis que je suis passé en 3.6..
    run time error 2147417848 (80010108)...
    J'ai fait quelques recherches sur le net mais tout ce que j'ai trouvé c'est que c'est une erreur fréquente sur les windows XP et qui n'est (je pense/je crois) pas résolvable.. Avez vous déjà vu cette erreur ci avant?

Discussions similaires

  1. Problème de compatibilité entre IE et FireFox
    Par paradeofphp dans le forum Balisage (X)HTML et validation W3C
    Réponses: 2
    Dernier message: 19/09/2006, 14h39
  2. Réponses: 5
    Dernier message: 16/03/2006, 00h09
  3. Réponses: 4
    Dernier message: 06/03/2006, 20h14
  4. Problème de compatibilité entre deux scripts
    Par frutix dans le forum JavaScript
    Réponses: 2
    Dernier message: 20/01/2006, 14h24
  5. Problèmes de compatibilité entre sdk 9.0c et geforce 2/4
    Par Francky033 dans le forum DirectX
    Réponses: 2
    Dernier message: 01/10/2004, 14h22

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo