Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 13 sur 13
  1. #1
    Futur Membre du Club
    Inscrit en
    avril 2005
    Messages
    112
    Détails du profil
    Informations forums :
    Inscription : avril 2005
    Messages : 112
    Points : 17
    Points
    17

    Par défaut [postgis] probleme installation

    Bonjour,

    J'essaye d'installer postgresql8.4/postgis1.5.2 à l'aide du package disponible ici. (postgreSQL -> win32)
    L'installation de postgis bloque presqu'à la fin sur la tâche "creating template database".
    Si postgresql est bien installé, postgis ne l'est pas après l'abandon de l'installation.
    Qui connaitrait la cause de l’échec de l'installation de postgis svp ?
    Merci

    config : windows 7 pro SP1

  2. #2
    Responsable Livres

    Avatar de MaitrePylos
    Homme Profil pro Gérard Ernaelsten
    DBA & Dev PHP
    Inscrit en
    juin 2005
    Messages
    3 841
    Détails du profil
    Informations personnelles :
    Nom : Homme Gérard Ernaelsten
    Âge : 41
    Localisation : Belgique

    Informations professionnelles :
    Activité : DBA & Dev PHP
    Secteur : Service public

    Informations forums :
    Inscription : juin 2005
    Messages : 3 841
    Points : 8 781
    Points
    8 781

    Par défaut

    Je suppose que tu essayes d'installer PostGis via l'installateur de EntrepriseDb?

    Va chercher PostGis Ici et installe-le à la mano, de toute façon tu devras faire quelques manipulations pour initialiser un Db spatial.

  3. #3
    Futur Membre du Club
    Inscrit en
    avril 2005
    Messages
    112
    Détails du profil
    Informations forums :
    Inscription : avril 2005
    Messages : 112
    Points : 17
    Points
    17

    Par défaut

    Citation Envoyé par MaitrePylos Voir le message
    Je suppose que tu essayes d'installer PostGis via l'installateur de EntrepriseDb?
    exactement

    Citation Envoyé par MaitrePylos Voir le message
    Va chercher PostGis Ici et installe le à la mano, de toute façon tu devras faire quelque manipulation pour initialiser un Db spatial.
    j essaie asap et je tiens au courant
    merci

  4. #4
    Futur Membre du Club
    Inscrit en
    avril 2005
    Messages
    112
    Détails du profil
    Informations forums :
    Inscription : avril 2005
    Messages : 112
    Points : 17
    Points
    17

    Par défaut

    echec de l'installation ; ca bloque à "checking for existing PostGis installation" soit au début de l'install.
    Windows 7 ne serait pas la cause de l'échec ?
    J ai à priori rien trouvé en ce sens mais bon...

    ps : j ai téléchargé PostGIS 1.5.2 release for PostgreSQL 8.4

  5. #5
    Expert Confirmé
    Profil pro
    Inscrit en
    octobre 2008
    Messages
    1 832
    Détails du profil
    Informations personnelles :
    Localisation : France, Paris (Île de France)

    Informations forums :
    Inscription : octobre 2008
    Messages : 1 832
    Points : 2 766
    Points
    2 766

    Par défaut

    Est-ce que la commande renvoie quelque chose?
    (se mettre dans le répertoire où est installé psql.exe s'il n'est pas dans le PATH)

    C'est pour voir s'il est déjà possible de se connecter au serveur.

  6. #6
    Futur Membre du Club
    Inscrit en
    avril 2005
    Messages
    112
    Détails du profil
    Informations forums :
    Inscription : avril 2005
    Messages : 112
    Points : 17
    Points
    17

    Par défaut

    la commande renvoie ceci :

    diagnostic ?

  7. #7
    Expert Confirmé
    Profil pro
    Inscrit en
    octobre 2008
    Messages
    1 832
    Détails du profil
    Informations personnelles :
    Localisation : France, Paris (Île de France)

    Informations forums :
    Inscription : octobre 2008
    Messages : 1 832
    Points : 2 766
    Points
    2 766

    Par défaut

    Ca montre que le serveur répond bien, le résultat de la commande psql -l est complètement normal.

  8. #8
    Futur Membre du Club
    Inscrit en
    avril 2005
    Messages
    112
    Détails du profil
    Informations forums :
    Inscription : avril 2005
    Messages : 112
    Points : 17
    Points
    17

    Par défaut

    ok bien

    et pour postgis du coup ?

  9. #9
    Responsable Livres

    Avatar de MaitrePylos
    Homme Profil pro Gérard Ernaelsten
    DBA & Dev PHP
    Inscrit en
    juin 2005
    Messages
    3 841
    Détails du profil
    Informations personnelles :
    Nom : Homme Gérard Ernaelsten
    Âge : 41
    Localisation : Belgique

    Informations professionnelles :
    Activité : DBA & Dev PHP
    Secteur : Service public

    Informations forums :
    Inscription : juin 2005
    Messages : 3 841
    Points : 8 781
    Points
    8 781

    Par défaut

    Bonjour,

    Vérifie que tu n'as pas les fichiers qui te concernent dans /REPERTOIRE_INSTALL_POSTGRES/PosgreSQL/share/contrib/

    tu devrais y voir un fichier : spatial_ref_sys.sql

    Sinon désinstalle et recommence la procédure.

  10. #10
    Futur Membre du Club
    Inscrit en
    avril 2005
    Messages
    112
    Détails du profil
    Informations forums :
    Inscription : avril 2005
    Messages : 112
    Points : 17
    Points
    17

    Par défaut

    dans /contrib j ai :
    un répertoire postgis
    un répertoire postgis-1.5
    plein de fichiers sql... sauf spatial_ref_sys.sql

    je vais recommencer l'installation de tout le truc mais ça fera la 3eme fois

  11. #11
    Futur Membre du Club
    Inscrit en
    avril 2005
    Messages
    112
    Détails du profil
    Informations forums :
    Inscription : avril 2005
    Messages : 112
    Points : 17
    Points
    17

    Par défaut

    le retour.

    J'ai tenté l'installation avec le stackbuilder sur un autre ordi sous xp.
    Impossible d'installer postgis également : même erreur "creation database failed". Ici en plus, impossible d'installer le serveur Apache.

    Si jamais quelqu'un a une idée lumineuse je suis preneur !

  12. #12
    Futur Membre du Club
    Inscrit en
    avril 2005
    Messages
    112
    Détails du profil
    Informations forums :
    Inscription : avril 2005
    Messages : 112
    Points : 17
    Points
    17

    Par défaut

    probleme résolu !

    je poste pour que ca serve à d'autres (éventuellement)


    sous Win 7 : si erreur postgis installation avec « postgis database creation failed ».
    Ou/et probleme au moment de l’installation de postgis avec un « template_postgis » qui n'existe pas mais que l install veut effacer…(!).

    ->La solution ici a été de créer une base template_postgis avec pgadminIII avec comme propriétaire postgres et de (re)lancer l’installation de postgis.

    rendons à César : http://old.nabble.com/Installing-pos...d22042310.html

  13. #13
    Responsable Livres

    Avatar de MaitrePylos
    Homme Profil pro Gérard Ernaelsten
    DBA & Dev PHP
    Inscrit en
    juin 2005
    Messages
    3 841
    Détails du profil
    Informations personnelles :
    Nom : Homme Gérard Ernaelsten
    Âge : 41
    Localisation : Belgique

    Informations professionnelles :
    Activité : DBA & Dev PHP
    Secteur : Service public

    Informations forums :
    Inscription : juin 2005
    Messages : 3 841
    Points : 8 781
    Points
    8 781

    Par défaut

    Merci pour le lien

    Je poste en résolu.

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •