+ Répondre à la discussion
Affichage des résultats 1 à 12 sur 12
  1. #1
    Invité régulier
    Homme Profil pro
    Etudiant Licence Bioinformatique
    Inscrit en
    juin 2011
    Messages
    16
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Cantal (Auvergne)

    Informations professionnelles :
    Activité : Etudiant Licence Bioinformatique
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : juin 2011
    Messages : 16
    Points : 6
    Points
    6

    Par défaut Problème accès phpmyadmin

    Bonjour,

    Quand je tente d'accéder à phpmyadmin via http://127.0.0.1/phpmyadmin/, le navigateur me renvoie ceci :
    Il manque l'extension mysqli. Veuillez vérifier votre configuration PHP.

    Or cette extension est présente physiquement dans le dossier 'ext' de PHP, de plus elle apparait dans le php.ini sans le ';' devant.

    Ma configuration actuelle est : Windows XP Pro SP3, Apache 2.2.19, PHP 5.3.6, MySQL 5.5.13 et phpMyAdmin 3.4.2.

    J'ai suivi le tutoriel de giminik en essayant de l'adapter par rapport à mes versions. Mais rien à faire, j'ai beau modifier les fichiers de configurations, déplacer des fichiers dans d'autres dossiers, j'obtiens toujours la même erreur.
    Apache et PHP fonctionne, quand je tape http://127.0.0.1/test.php, il me renvoie bien les informations.

    Merci d'avance pour vos réponses.

    Max

  2. #2
    Expert Confirmé Sénior
    Avatar de Benjamin Delespierre
    Profil pro Benjamin Delespierre
    Développeur Web
    Inscrit en
    février 2010
    Messages
    3 931
    Détails du profil
    Informations personnelles :
    Nom : Benjamin Delespierre
    Âge : 27
    Localisation : France, Alpes Maritimes (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : février 2010
    Messages : 3 931
    Points : 8 401
    Points
    8 401

    Par défaut

    Hello

    L'extension à beau être présente, elle n'est peut être tout simplement pas activée.
    Fais donc un clic gauche sur l'icône de wamp dans la barre des tâches puis PHP puis PHP Extensions et enfin tu coches php_mysqli.

    Si c'est pas ça, va voir dans le php.ini à la section réservée aux extensions pour l'activer.

  3. #3
    Invité régulier
    Homme Profil pro
    Etudiant Licence Bioinformatique
    Inscrit en
    juin 2011
    Messages
    16
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Cantal (Auvergne)

    Informations professionnelles :
    Activité : Etudiant Licence Bioinformatique
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : juin 2011
    Messages : 16
    Points : 6
    Points
    6

    Par défaut

    Bonjour,

    Je n'utilise pas wamp. J'installe les logiciels moi-même un à un.
    Dans le php.ini j'ai bien une ligne 'extension=php_mysqli.dll' sans ';' devant.
    Donc elle devrait être active, je suppose.
    D'autres idées ?
    Merci

    Max

  4. #4
    Expert Confirmé Sénior
    Avatar de Benjamin Delespierre
    Profil pro Benjamin Delespierre
    Développeur Web
    Inscrit en
    février 2010
    Messages
    3 931
    Détails du profil
    Informations personnelles :
    Nom : Benjamin Delespierre
    Âge : 27
    Localisation : France, Alpes Maritimes (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : février 2010
    Messages : 3 931
    Points : 8 401
    Points
    8 401

    Par défaut

    Qu'est ce que te donne le phpinfo ?

  5. #5
    Invité régulier
    Homme Profil pro
    Etudiant Licence Bioinformatique
    Inscrit en
    juin 2011
    Messages
    16
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Cantal (Auvergne)

    Informations professionnelles :
    Activité : Etudiant Licence Bioinformatique
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : juin 2011
    Messages : 16
    Points : 6
    Points
    6

    Par défaut

    Toute les infos correspondant à ma configuration apache, mysql, php.
    Maintenant phpMyAdmin fonctionne (dans le sens où je n'ai plus ce message d'erreur), est-ce dût au fait que j'ai redémarrer l'ordinateur après l'installation et la configuration des fichiers ?
    Maintenant il me demande de m'authentifier or en installant MySQL avec l'installeur je n'ai pas défini d'utilisateur root, donc phpMyAdmin renvoi accès refusé. Quand je modifie le service mysql pour modifier les infos de root, j'obtiens :
    The security settings could not be applied.
    Error Number 1045.
    Access denied for user 'root'@'localhost'(using password : NO)

    MAx

  6. #6
    Invité régulier
    Homme Profil pro
    Etudiant Licence Bioinformatique
    Inscrit en
    juin 2011
    Messages
    16
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Cantal (Auvergne)

    Informations professionnelles :
    Activité : Etudiant Licence Bioinformatique
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : juin 2011
    Messages : 16
    Points : 6
    Points
    6

    Par défaut

    Bonjour,

    Le problème d'accès de root est résolu grâce à un redémarrage des services, pour que la modification d'un fichier de configuration soit prise en compte.
    Dans mon réseau local je voudrais accéder à ma base de données via phpMyadmin à partir d'un autre poste de mon réseau.
    Quelle ligne de quel fichier dois-je modifier ?

    Max

  7. #7
    Invité de passage
    Homme Profil pro mike
    Consultant informatique
    Inscrit en
    septembre 2011
    Messages
    1
    Détails du profil
    Informations personnelles :
    Nom : Homme mike
    Localisation : France

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : Finance

    Informations forums :
    Inscription : septembre 2011
    Messages : 1
    Points : 1
    Points
    1

    Par défaut Ajouter un peu d'eau au moulin

    Pour avoir rencontrer ce problème :
    > Il manque l'extension mysqli. Veuillez vérifier votre configuration PHP.
    ou
    > Il manque l'extension mysql. Veuillez vérifier votre configuration PHP.

    voici ce qu'est fait pour le résoudre :

    1°) Vérifier le phpinfo :
    mettre ceci dans un fichier index.php
    <?php
    phpinfo();
    ?>
    puis afficher http://127.0.0.1/index.php dans l'explorer.
    Si la page phpinfo ne s'affiche pas ! revoir l'install du php.ini

    2°) Dans la page phpinfo, dois être présent une section mysqli ou mysql.

    Si cette section n'est pas présente,
    1°) - désactivé le serveur Apache.
    2°) - Edit php.ini
    Vérifier les lignes suivantes pour Mysqli (changer Mysqli par Mysql si c'est l'autre option que vous choisissez):
    extension=php_mysqli.dll
    ;extension=php_mysql.dll

    dans le bloc [MySQLi]
    mysqli.default_port = 3306
    mysqli.default_host = 127.0.0.1
    mysqli.default_user = root
    mysqli.default_pw = "votre mot de pass"
    mysqli.reconnect = Off
    3°) - enregistrer le fichier php.ini
    4°) - relancer votre serveur Apache
    5°) - Afficher le phpinfo la section mysqli doit apparaître (faite un refresh explorer si ce n'est pas le cas ! parfois il garde la précédente pas charger en mémoire)
    6°) - Lancer http://127.0.0.1/phpmyadmin/ (avec un petit refresh aussi)

    normalement, vous devriez avoir résolut votre problème (pour ça a fonctionné !)

    Vous pouvez rééditer les info de php.ini en supprimant les valeurs
    mysqli.default_host =
    mysqli.default_user =
    mysqli.default_pw =

    L'initialisation reste effective.
    en espérant avoir pu en aider certain !

  8. #8
    Invité de passage
    Inscrit en
    novembre 2011
    Messages
    1
    Détails du profil
    Informations forums :
    Inscription : novembre 2011
    Messages : 1
    Points : 1
    Points
    1

    Par défaut

    Une fois la ligne de l'extension pour mysql (extension=mysql.dll ou extension=mysqli.dll ) décommentée dans le php.ini, il faut ajouter la librairie libmysql.dll qui se trouve dans le répertoire de php dans le répertoire WINDOWS/system32 et relancer Apache pour que les modifications soient prises en compte.

  9. #9
    Expert Confirmé Sénior
    Avatar de Benjamin Delespierre
    Profil pro Benjamin Delespierre
    Développeur Web
    Inscrit en
    février 2010
    Messages
    3 931
    Détails du profil
    Informations personnelles :
    Nom : Benjamin Delespierre
    Âge : 27
    Localisation : France, Alpes Maritimes (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : février 2010
    Messages : 3 931
    Points : 8 401
    Points
    8 401

    Par défaut

    Vu les problèmes que tu rencontres, tu devrais vraiment considérer l'usage de WAMP ce qui te simplifierai bien la vie. L'installation manuelle c'est pour ceux qui connaissent et savent configurer une stack WAMP/LAMP.

    Q: Qu'est ce que te donne le phpinfo ?
    A: Toute les infos correspondant à ma configuration apache, mysql, php.
    Je m'en serai pas douté. Dans le listing, on a la liste des extensions chargées ainsi que leurs paramètres, c'est là qu'il faut regarder pour vérifier si un module installé à bien été chargé.

    Citation Envoyé par CCPMurat Voir le message
    Le problème d'accès de root est résolu grâce à un redémarrage des services
    Note: après une modification de php.ini il faut toujours recharger la configuration d'apache ou le redémarrer.

    pour que la modification d'un fichier de configuration soit prise en compte.
    Dans mon réseau local je voudrais accéder à ma base de données via phpMyadmin à partir d'un autre poste de mon réseau.
    Quelle ligne de quel fichier dois-je modifier ?
    Il faut ajouter une règle dans httpd.conf:
    Code :
    1
    2
    3
    4
    5
    6
    <Directory "c:/chemin/ver/php/my/admin/">
        Options Indexes FollowSymLinks
        AllowOverride all
        Order Allow,Deny
        Allow from all
    </Directory>
    Ainsi, le répertoire est accessible sur tout le réseau local.

    Code :
    1
    2
    3
    4
    Maintenant il me demande de m'authentifier or en installant MySQL avec l'installeur je n'ai pas défini d'utilisateur root, donc phpMyAdmin renvoi accès refusé. Quand je modifie le service mysql pour modifier les infos de root, j'obtiens :
    The security settings could not be applied.
    Error Number 1045.
    Access denied for user 'root'@'localhost'(using password : NO)
    Utilise la commande "mysql" dans un terminal (positionne toi dans le répertoire bin de mysql si tu n'a pas paramétré le PATH en conséquence) et fait l'ajout d'utilisateurs à la main: http://dev.mysql.com/doc/refman/5.1/...ing-users.html

  10. #10
    Futur Membre du Club
    Profil pro
    Inscrit en
    juillet 2009
    Messages
    14
    Détails du profil
    Informations personnelles :
    Âge : 33
    Localisation : France, Maine et Loire (Pays de la Loire)

    Informations forums :
    Inscription : juillet 2009
    Messages : 14
    Points : 16
    Points
    16

    Par défaut Directive PHPIniDir

    Bonjour,

    À préciser que sans la directive PHPIniDir dans httpd.conf, le fichier php.ini ne sera pas lu et les extensions supplémentaires non chargées.

    Par exemple, si le fichier Php.ini se trouve à C:\Program Files\Php\Php.ini, il faut indiquer dans httpd.conf :

    PHPIniDir "C:\Program Files\Php"

  11. #11
    Invité régulier
    Profil pro Laurent P.
    Inscrit en
    juillet 2010
    Messages
    19
    Détails du profil
    Informations personnelles :
    Nom : Laurent P.

    Informations forums :
    Inscription : juillet 2010
    Messages : 19
    Points : 5
    Points
    5

    Par défaut

    J'ajoute une précision sur ce _vieux_ post...

    Je me suis cassé les dents sur le même problème. Après avoir longtemps galéré j'ai découvert que l'erreur venait de cette directive du fichier httpd.conf :

    PHPIniDir "C:\Program Files\Php"

    J'avais écrit à la place :
    PHPIniDir "C:\Program Files\Php\"

    L'antislash final a visiblement tout bloqué.

    A noter que si vous avez ce genre de problème (pas de mysql ou mysqli en PHP), vérifiez dans le phpinfo() que le chemin extension_dir est correct. Si ce n'est pas le cas il ne trouvera pas les dll et donc ne pourra pas charger le support mysql/mysqli.

  12. #12
    Membre du Club
    Inscrit en
    décembre 2006
    Messages
    136
    Détails du profil
    Informations forums :
    Inscription : décembre 2006
    Messages : 136
    Points : 62
    Points
    62

    Par défaut phpmyadmin - Erreur il manque l'extension mysqli

    Pour compléter la réponse j'ai eu cette difficulté et pour le résoudre j'ai du changer le nom de l'extension dans le config.inc.php du répertoire phpmyadmin<version>/:
    j'avais ceci :
    $cfg['Servers'][$i]['extension'] = 'mysqli';

    et j'ai mis ceci :
    $cfg['Servers'][$i]['extension'] = 'php_mysqli';

    et cela a fonctionné aprés reboot du server.

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •