Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 7 sur 7
  1. #1
    Membre éclairé
    Profil pro
    Inscrit en
    avril 2009
    Messages
    735
    Détails du profil
    Informations personnelles :
    Âge : 37
    Localisation : France, Somme (Picardie)

    Informations forums :
    Inscription : avril 2009
    Messages : 735
    Points : 389
    Points
    389

    Par défaut comment installer postgresql-8.2 sur debian 4 etch ?

    Bonjour,

    Je continue mon parcours d'installation d'un vieil applicatif sous debian 4 etch dans ma VM...

    Je me heurte cette fois-ci à l'installation de postgresql en version 8.2 (pas 8.3, pas 8.4, ni 9.xs sinon mon application ne marchera pas/bugguera).
    Dans ma vieille doc (du temps ou la etch était Ok) j'avais noté :

    Code :
    apt-get install postgresql-8.2
    Aujourd'hui (2011, etch obsolète), quand je tape (en root) la même ligne de commande , j'obtiens :

    impossible de trouver le paquet postgresql-8.2
    J'ai pourtant fait mon update avant et mon sourcelist est sur archive...

    Que faire ? Comment installer spécifiquement la version 8.2 (si possible la dernière 8.2.21, ce serait génial).

    merci de votre aide.

    Mike

  2. #2
    Responsable Livres

    Avatar de MaitrePylos
    Homme Profil pro Gérard Ernaelsten
    DBA & Dev PHP
    Inscrit en
    juin 2005
    Messages
    3 806
    Détails du profil
    Informations personnelles :
    Nom : Homme Gérard Ernaelsten
    Âge : 41
    Localisation : Belgique

    Informations professionnelles :
    Activité : DBA & Dev PHP
    Secteur : Service public

    Informations forums :
    Inscription : juin 2005
    Messages : 3 806
    Points : 8 120
    Points
    8 120

    Par défaut

    Que donne

    Code :
    1
    2
     
    apt-get search postgresql

  3. #3
    Membre éclairé
    Profil pro
    Inscrit en
    avril 2009
    Messages
    735
    Détails du profil
    Informations personnelles :
    Âge : 37
    Localisation : France, Somme (Picardie)

    Informations forums :
    Inscription : avril 2009
    Messages : 735
    Points : 389
    Points
    389

    Par défaut

    apt-get search ne fonctionne pas, je fais à la place
    Code :
    apt-cache search postgresql-8
    et je vois qu'il y a la 8.1 mais c'est insuffisant...

  4. #4
    Expert Confirmé
    Profil pro
    Inscrit en
    octobre 2008
    Messages
    1 822
    Détails du profil
    Informations personnelles :
    Localisation : France, Paris (Île de France)

    Informations forums :
    Inscription : octobre 2008
    Messages : 1 822
    Points : 2 517
    Points
    2 517

    Par défaut

    En principe il devrait être dans les backports de etch mais en fait non car debian 5 a adopté postgresql-8.3 et non 8.2.
    On peut donc installer via apt une 8.3 sous etch mais pas une 8.2.
    Le plus simple maintenant est sans doute de le compiler soi-même à partir des sources.

  5. #5
    Invité de passage
    Inscrit en
    décembre 2008
    Messages
    16
    Détails du profil
    Informations forums :
    Inscription : décembre 2008
    Messages : 16
    Points : 4
    Points
    4

    Par défaut

    Citation Envoyé par estofilo Voir le message
    En principe il devrait être dans les backports de etch mais en fait non car debian 5 a adopté postgresql-8.3 et non 8.2.
    On peut donc installer via apt une 8.3 sous etch mais pas une 8.2.
    Le plus simple maintenant est sans doute de le compiler soi-même à partir des sources.

    Mon problème est un peu différent : j'ai une etch (debian 4) mais impossible de trouver le backport pour postgresql 8.3 pour la etch.

    Tu n'aurais pas un lien pour récupérer l'apt par le backport ??

    merci de ton aide

  6. #6
    Membre éclairé
    Profil pro
    Inscrit en
    avril 2009
    Messages
    735
    Détails du profil
    Informations personnelles :
    Âge : 37
    Localisation : France, Somme (Picardie)

    Informations forums :
    Inscription : avril 2009
    Messages : 735
    Points : 389
    Points
    389

    Par défaut

    si tu peux, install KDE (4.3) et ensuite le package binaire qui comporte la panoplie de 8.3 (de entreprisedb).

  7. #7
    Expert Confirmé
    Profil pro
    Inscrit en
    octobre 2008
    Messages
    1 822
    Détails du profil
    Informations personnelles :
    Localisation : France, Paris (Île de France)

    Informations forums :
    Inscription : octobre 2008
    Messages : 1 822
    Points : 2 517
    Points
    2 517

    Par défaut

    Les backports de etch sont obsolètes mais les paquets non maintenus sont toujours récupérables à partir d'ici:
    http://archive.debian.org/debian-backports

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •