p
u
b
l
i
c
i
t
é
publicité
  1. #21
    Nouveau Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2012
    Messages
    71
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mai 2012
    Messages : 71
    Points : 25
    Points
    25

    Par défaut

    merci ba jai fait la modif , redemarer le serveur et .. sa marche pas .. ^^

  2. #22
    Expert Confirmé Sénior

    Inscrit en
    septembre 2010
    Messages
    7 957
    Détails du profil
    Informations forums :
    Inscription : septembre 2010
    Messages : 7 957
    Points : 10 641
    Points
    10 641

    Par défaut

    t'as bien vérifier dans le phpinfo si c’était modifié (le error_reporting) ?

  3. #23
    Nouveau Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2012
    Messages
    71
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mai 2012
    Messages : 71
    Points : 25
    Points
    25

    Par défaut

    voila ce que me dit phpinfo : error_reporting 24575 dans la partie CORE

  4. #24
    Expert Confirmé Sénior

    Inscrit en
    septembre 2010
    Messages
    7 957
    Détails du profil
    Informations forums :
    Inscription : septembre 2010
    Messages : 7 957
    Points : 10 641
    Points
    10 641

    Par défaut

    coté conf c'est OK, maintenant le code doit change ça quelque par, regarde les error_reporting et les ini_set qui traine

  5. #25
    Nouveau Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2012
    Messages
    71
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mai 2012
    Messages : 71
    Points : 25
    Points
    25

    Par défaut

    alors jai fait une recherche, les ini_set on l'air cleen, par contre jai deux error_reporting sur deux fichier differents, ses fichier sont dans pear :

    fichier 1 :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    function PEAR_RunTest($logger = null, $options = array())
        {
            if (!defined('E_DEPRECATED')) {
                define('E_DEPRECATED', 0);
            }
            if (!defined('E_STRICT')) {
                define('E_STRICT', 0);
            }
            $this->ini_overwrites[] = 'error_reporting=' . (E_ALL & ~(E_DEPRECATED | E_STRICT));
            if (is_null($logger)) {
                require_once 'PEAR/Common.php';
                $logger = new PEAR_Common;
            }
            $this->_logger  = $logger;
            $this->_options = $options;
     
            $conf = &PEAR_Config::singleton();
            $this->_php = $conf->get('php_bin');
        }
    fichier 2 :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    function error_handler($errno, $errmsg, $file, $line, $vars) {
        if ((defined('E_STRICT') && $errno & E_STRICT) || (defined('E_DEPRECATED') &&
              $errno & E_DEPRECATED) || !error_reporting()) {
            if (defined('E_STRICT') && $errno & E_STRICT) {
                return; // E_STRICT
            }
            if (defined('E_DEPRECATED') && $errno & E_DEPRECATED) {
                return; // E_DEPRECATED
            }
            if ($GLOBALS['config']->get('verbose') < 4) {
                return false; // @silenced error, show all if debug is high enough
            }
        }

+ Répondre à la discussion
Cette discussion est résolue.
Page 2 sur 2 PremièrePremière 12

Discussions similaires

  1. Réponses: 8
    Dernier message: 02/10/2013, 21h35
  2. manuel d'utilisation de fonction
    Par SteelBox dans le forum Langages de programmation
    Réponses: 1
    Dernier message: 11/10/2004, 01h28
  3. Utiliser des fonctions Pascal
    Par Neilos dans le forum C++Builder
    Réponses: 2
    Dernier message: 07/03/2004, 15h43
  4. Réponses: 11
    Dernier message: 22/12/2003, 21h06
  5. impossible d'utiliser ma fonction dans un insert
    Par caramel dans le forum MS SQL-Server
    Réponses: 2
    Dernier message: 10/04/2003, 15h04

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo