Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 4 sur 4
  1. #1
    Nouveau Membre du Club
    Profil pro
    Inscrit en
    septembre 2008
    Messages
    46
    Détails du profil
    Informations personnelles :
    Âge : 31
    Localisation : France, Loiret (Centre)

    Informations forums :
    Inscription : septembre 2008
    Messages : 46
    Points : 36
    Points
    36

    Par défaut Installation / utilisation PGLOADER 2.3

    Bonjour à tous,

    J'expose mon ou plutôt mes soucis.

    Je dois alimenter via un loader plusieurs tables d'une Base PostgreSQL v9.
    La plate forme OS est un AIX 5.3.

    Le loader que je souhaiterais utiliser est pgloader, cf http://pgfoundry.org/projects/pgloader/

    Cependant, je n'arrive pas à le faire fonctionner depuis mon serveur.
    Je n'ai aucune connaissance en Python pour savoir comment lancer , ou encore même paramétrer mon environnement unix

    Exemple d'erreur :

    Code :
    1
    2
    3
    TUNING-POSTGRESQL:mnx49:/BASE/postgres/pgloader-2.3.2/pgloader (983):./pgloader.py -vc /BASE/postgres/pgloader_WEBDW.conf
    ./pgloader.py[8]: import:  NOT found
    ./pgloader.py[28]: syntax error at line 28 : `(' unexpected
    Bref, en résumé je nage sur la façon de faire fonctionner cet outil.
    Le make ne passe pas :

    Code :
    1
    2
    3
    4
    TUNING-POSTGRESQL:mnx49:/BASE/postgres/pgloader-2.3.2 (986):make
    install -m 755 pgloader.py /usr/bin/pgloader
    install: File 755 was NOT found.
    make: *** [install] Error 2
    Quelqu'un pourrais t'il m'aider pour réussir à lancer ce *ù^!:~!$ de binaire

    Merci !

    Mick

  2. #2
    Nouveau Membre du Club
    Profil pro
    Inscrit en
    septembre 2008
    Messages
    46
    Détails du profil
    Informations personnelles :
    Âge : 31
    Localisation : France, Loiret (Centre)

    Informations forums :
    Inscription : septembre 2008
    Messages : 46
    Points : 36
    Points
    36

    Par défaut

    Aie, Personne n'a utilisé cet outil ???

    merci,
    Mick.

  3. #3
    Expert Confirmé
    Profil pro
    Inscrit en
    octobre 2008
    Messages
    1 818
    Détails du profil
    Informations personnelles :
    Localisation : France, Paris (Île de France)

    Informations forums :
    Inscription : octobre 2008
    Messages : 1 818
    Points : 2 507
    Points
    2 507

    Par défaut

    Personnellement non, mais au vu des messages d'erreur le problème vient du fait que l'install de l'outil n'est pas vraiment supportée sur AIX.

    Sinon, tu aurais peut-être plus de succès en contactant directement le mainteneur du programme, qui je crois est français.

  4. #4
    Nouveau Membre du Club
    Profil pro
    Inscrit en
    septembre 2008
    Messages
    46
    Détails du profil
    Informations personnelles :
    Âge : 31
    Localisation : France, Loiret (Centre)

    Informations forums :
    Inscription : septembre 2008
    Messages : 46
    Points : 36
    Points
    36

    Par défaut

    Merci pour ta réponse, effectivement le developpeur du programme est francais. Je vais donc le contacter pour avoir plus d'infos sur AIX.

    Mais il est probable que ma plate forme ne convienne pas..

    Je ferais un retour sur ce post dès que j'aurais eu des nouvelles.

    Merci,

    Mik

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •