Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 3 sur 3
  1. #1
    Invité régulier
    Inscrit en
    février 2009
    Messages
    43
    Détails du profil
    Informations forums :
    Inscription : février 2009
    Messages : 43
    Points : 6
    Points
    6

    Par défaut [XL-2002] Résultat de la formule ne s'affiche pas

    Bonjour,

    J'utilise un SOMME.SI classique. Dans certaines cellules le résultat ne s'affiche pas, ou plutôt il est incorrect. En effet la cellule renvoie la valeur 0 alors que ce n'est pas le résultat correct. Quand on regarde le résultat de la formule en cliquant sur fx dans la barre des formules, on voit le résultat correct (par exemple 223).

    Cette formule vient d'un copier/coller d'une autre feuille. Ne fonctionnant pas, j'ai remplacé les cellules défaillantes par des cellules vides et j'ai taper la formule manuellement. Comme le problème persistait j'ai fait glisser la cellule précédente, qui elle aussi a cette formule, sur la cellule défaillante. Rien y fait.

    Ma formule est bonne puisqu'elle fonctionne sur d'autres cellules. Les arguments de la fonction sont les mêmes pour ces cellules, seuls les critères (2eme argument) changent. Sur d'autres feuilles, je n'ai pas de problème alors que c'est la même chose.

    Je ne comprend pas et ça me prend la tête.

    Est-ce que quelq'un aurait une solution ?

  2. #2
    Membre actif
    Profil pro Bert Tranz
    Inscrit en
    juillet 2008
    Messages
    149
    Détails du profil
    Informations personnelles :
    Nom : Bert Tranz
    Localisation : France, Paris (Île de France)

    Informations forums :
    Inscription : juillet 2008
    Messages : 149
    Points : 156
    Points
    156

    Par défaut

    Pour vraiment trouver uen soltuion, il faudrait que tu affiches la formule dans le post soit ou tu mettes le fichier mais ça doit être un problème de construction de ta formule ou de format :
    - As-tu bien verrouillé les cellulles (avec les $) pour les plages ?
    - Les données de ta base et de ton critère sont-elles exactement les mêmes ? (problèmes d'espace, de formats de cellulles...)
    Cdlt

  3. #3
    Invité régulier
    Inscrit en
    février 2009
    Messages
    43
    Détails du profil
    Informations forums :
    Inscription : février 2009
    Messages : 43
    Points : 6
    Points
    6

    Par défaut

    J'ai trouvé ! L'argument de somme est une colonne avec des MAX(). Un de ces MAX() avait pour argument une ligne où il y avait une erreur. En effet, une cellule de cette ligne avait une SOMME qui se prenait pour argument. Ca ne renvoyait pas de valeur (et pas d'erreur) mais ça empêchait le MAX() de fonctionnait, il renvoyait 0. Ce 0 était prix en compte dans mon SOMME.SI et l'empêchait à son tour de fonctionner.
    Comme on est plusieurs à utiliser ce fichier, et que certains ne comprennent pas comment fonctionnent les formules, je n'étais pas au courant de cette erreur.
    Désolé de t'avoir fait perdre ton temps mais merci pour m'avoir répondu.

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •