p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Invité régulier
    Inscrit en
    janvier 2008
    Messages
    57
    Détails du profil
    Informations forums :
    Inscription : janvier 2008
    Messages : 57
    Points : 7
    Points
    7

    Par défaut problème avec pgrfilemanager

    Bonjour,

    J'ai un soucis avec pgrfilemanager (que j'ai couplé avec ckeditor) car en local il fonctionne parfaitement, en revanche sur mon site j'ai une erreur :

    Parse error: syntax error, unexpected T_IS_EQUAL, expecting '(' .../ckeditor/plugins/pgrfilemanager/PGRFileManager.php on line 28"
    La ligne 28 du fichier en question correspond à

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
      if (PGRFileManagerConfig::$allowedExtensions == "") $PGRUploaderExtension = "*.*";  "
    N'étant pas un pro du php et n'ayant rien trouvé sur les forums, quelqu'un pourrait-il m'indiquer comment résoudre mon problème ?

    Merci d'avance

  2. #2
    Responsable Livres

    Avatar de MaitrePylos
    Homme Profil pro
    DBA & Dev PHP
    Inscrit en
    juin 2005
    Messages
    4 068
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 42
    Localisation : Belgique

    Informations professionnelles :
    Activité : DBA & Dev PHP
    Secteur : Service public

    Informations forums :
    Inscription : juin 2005
    Messages : 4 068
    Points : 9 172
    Points
    9 172

    Par défaut

    J'imagine qu'en local tu es sur Windows et que en hébergement tu es sur du Linux?

    Ton souci viens du fait qu'il y a un point de trop sur le chemin

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    EQUAL, expecting '(' .../ckeditor/plugins/pgrfilemanager/PGRFileManager.php on line 28"

  3. #3
    Invité régulier
    Inscrit en
    janvier 2008
    Messages
    57
    Détails du profil
    Informations forums :
    Inscription : janvier 2008
    Messages : 57
    Points : 7
    Points
    7

    Par défaut

    Merci tout d'abord pour ta réponse.

    Alors pour répondre à ta question oui tout à fait.

    Maintenant j'ai mis .../ pour résumer le chemin. En réalité, il y a un chemin complet sur la formulation de l'erreur du style htdocblablabla/blablabla/ckeditor/etc.

    Ceci dit, cela ne change rien, car je n'ai pas de chemin sur ma ligne 28, correspondant à mon erreur.

    Pour rappel :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
     if (PGRFileManagerConfig::$allowedExtensions == "") $PGRUploaderExtension = "*.*";

  4. #4
    Invité régulier
    Inscrit en
    janvier 2008
    Messages
    57
    Détails du profil
    Informations forums :
    Inscription : janvier 2008
    Messages : 57
    Points : 7
    Points
    7

    Par défaut

    En copiant l'url de l'image placée sur mon serveur et en la collant depuis l'éditeur texte de ckeditor, cela semble fonctionner.

    Ceci dit, je ne comprends toujours pas l'origine de cette erreur qui m'est affichée lorsque je fais appel à pgrfilemanager.

    Si quelqu'un à une solution, il sera le bienvenu !!!

  5. #5
    Responsable Livres

    Avatar de MaitrePylos
    Homme Profil pro
    DBA & Dev PHP
    Inscrit en
    juin 2005
    Messages
    4 068
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 42
    Localisation : Belgique

    Informations professionnelles :
    Activité : DBA & Dev PHP
    Secteur : Service public

    Informations forums :
    Inscription : juin 2005
    Messages : 4 068
    Points : 9 172
    Points
    9 172

    Par défaut

    montre nous un peu avant la ligne 28 et un peu après

  6. #6
    Invité régulier
    Inscrit en
    janvier 2008
    Messages
    57
    Détails du profil
    Informations forums :
    Inscription : janvier 2008
    Messages : 57
    Points : 7
    Points
    7

    Par défaut

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
     <?php  include_once dirname(__FILE__) . '/php/init.php';
        $PGRUploaderExtension = "";
        if (PGRFileManagerConfig::$allowedExtensions == "") $PGRUploaderExtension = "*.*";
        else
        foreach(explode("|", PGRFileManagerConfig::$allowedExtensions) as $key => $extension) { 
            if ($key > 0) $PGRUploaderExtension .= ";";
            $PGRUploaderExtension .= "*." . $extension;   
        }
    ?>

  7. #7
    Responsable Livres

    Avatar de MaitrePylos
    Homme Profil pro
    DBA & Dev PHP
    Inscrit en
    juin 2005
    Messages
    4 068
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 42
    Localisation : Belgique

    Informations professionnelles :
    Activité : DBA & Dev PHP
    Secteur : Service public

    Informations forums :
    Inscription : juin 2005
    Messages : 4 068
    Points : 9 172
    Points
    9 172

    Par défaut

    Essaye une fois ce code

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
     
     
    <?php  include_once dirname(__FILE__) . '/php/init.php';
        $PGRUploaderExtension = "";
        if (PGRFileManagerConfig::$allowedExtensions == ""){ $PGRUploaderExtension = "*.*";}
        else{
        foreach(explode("|", PGRFileManagerConfig::$allowedExtensions) as $key => $extension) { 
            if ($key > 0) {$PGRUploaderExtension .= ";";}
            $PGRUploaderExtension .= "*." . $extension;   
        }}
    ?>

  8. #8
    Invité régulier
    Inscrit en
    janvier 2008
    Messages
    57
    Détails du profil
    Informations forums :
    Inscription : janvier 2008
    Messages : 57
    Points : 7
    Points
    7

    Par défaut

    C'est gentil, mais j'ai toujours cette même foutue erreur

  9. #9
    Modérateur
    Avatar de sabotage
    Homme Profil pro
    Inscrit en
    juillet 2005
    Messages
    24 179
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : juillet 2005
    Messages : 24 179
    Points : 35 565
    Points
    35 565

    Par défaut

    Est-ce que ton hebergement ne serait pas en PHP4 ?

  10. #10
    Invité régulier
    Inscrit en
    janvier 2008
    Messages
    57
    Détails du profil
    Informations forums :
    Inscription : janvier 2008
    Messages : 57
    Points : 7
    Points
    7

    Par défaut

    Euh oui effectivement, c'est du php 4

  11. #11
    Responsable Livres

    Avatar de MaitrePylos
    Homme Profil pro
    DBA & Dev PHP
    Inscrit en
    juin 2005
    Messages
    4 068
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 42
    Localisation : Belgique

    Informations professionnelles :
    Activité : DBA & Dev PHP
    Secteur : Service public

    Informations forums :
    Inscription : juin 2005
    Messages : 4 068
    Points : 9 172
    Points
    9 172

    Par défaut

    Citation Envoyé par sabotage Voir le message
    Est-ce que ton hebergement ne serait pas en PHP4 ?
    Tiens j'y avais pas pensé

    PHP4, ne reconnais pas le mot clé static

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
     
    class PGRFileManagerConfig
    {
        static public $rootDir;
        static public $rootPath;
        static public $urlPath;
        static public $pgrThumbPath;
        static public $fileMaxSize;
        static public $allowedExtensions = '';
        static public $imagesExtensions;
        static public $imageMaxHeight;
        static public $imageMaxWidth;
        static public $allowEdit;
        static public $authorize;
        static public $authorizeUser;
        static public $authorizePass;
        static public $ckEditorScriptPath;
        static public $ckEditorExtensions;
    }

  12. #12
    Invité régulier
    Inscrit en
    janvier 2008
    Messages
    57
    Détails du profil
    Informations forums :
    Inscription : janvier 2008
    Messages : 57
    Points : 7
    Points
    7

    Par défaut

    Et donc je fais comment pour y remédier ???

  13. #13
    Responsable Livres

    Avatar de MaitrePylos
    Homme Profil pro
    DBA & Dev PHP
    Inscrit en
    juin 2005
    Messages
    4 068
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 42
    Localisation : Belgique

    Informations professionnelles :
    Activité : DBA & Dev PHP
    Secteur : Service public

    Informations forums :
    Inscription : juin 2005
    Messages : 4 068
    Points : 9 172
    Points
    9 172

    Par défaut

    Première chose, qui est ton Hébergeur? Peut-être qu'il offre le support PHP5

  14. #14
    Invité régulier
    Inscrit en
    janvier 2008
    Messages
    57
    Détails du profil
    Informations forums :
    Inscription : janvier 2008
    Messages : 57
    Points : 7
    Points
    7

    Par défaut

    Je suis chez 1and1

  15. #15
    Modérateur
    Avatar de sabotage
    Homme Profil pro
    Inscrit en
    juillet 2005
    Messages
    24 179
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : juillet 2005
    Messages : 24 179
    Points : 35 565
    Points
    35 565

    Par défaut

    Ils permettent le PHP5 :
    http://faq.1and1.fr/scripts/php/5.html

  16. #16
    Invité régulier
    Inscrit en
    janvier 2008
    Messages
    57
    Détails du profil
    Informations forums :
    Inscription : janvier 2008
    Messages : 57
    Points : 7
    Points
    7

    Par défaut

    C'est super cool, ça fonctionne maintenant.

    Merci pour le tuyau

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. VC++ Direct3D8, problème avec LPD3DXFONT et LPD3DTEXTURE8
    Par Magus (Dave) dans le forum DirectX
    Réponses: 3
    Dernier message: 03/08/2002, 11h10
  2. Problème avec [b]struct[/b]
    Par Bouziane Abderraouf dans le forum CORBA
    Réponses: 2
    Dernier message: 17/07/2002, 10h25
  3. Problème avec le type 'Corba::Any_out'
    Par Steven dans le forum CORBA
    Réponses: 2
    Dernier message: 14/07/2002, 18h48
  4. Problème avec la mémoire virtuelle
    Par Anonymous dans le forum CORBA
    Réponses: 13
    Dernier message: 16/04/2002, 16h10

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo