p
u
b
l
i
c
i
t
é
publicité

Discussion: Le stimulus de MPLAB

  1. #1
    Invité de passage
    Inscrit en
    septembre 2006
    Messages
    55
    Détails du profil
    Informations forums :
    Inscription : septembre 2006
    Messages : 55
    Points : 4
    Points
    4

    Par défaut Le stimulus de MPLAB

    bonjour,

    je viens de réduire au max mon programme pour plus de facilité de compréhension, mais avec cette "bizarrerie".
    Dans le stimulus "copie(2).sbs" sont simulées les entrées RB0 et RB7 à différentes valeurs de temps .
    J'ai remarqué que la simulation de ces entrées ne fonctionne plus à partir de 27secondes (alors que la simulation court jusqu'à 40s ... aucun changement d'état dans le registre PORTB du SFR) mais par contre j'ai l'interruption ....... qui ne correspond à rien car RB0 et RB7 restent au zéro logique !!!!
    Normal ou pas ?

    Je joins une copie du programme ainsi que le stimulus à joindre dans MPLAB IDE v7.50 que j'utilise.

    Arzew
    Fichiers attachés Fichiers attachés

  2. #2
    Nouveau Membre du Club

    Inscrit en
    mars 2008
    Messages
    62
    Détails du profil
    Informations forums :
    Inscription : mars 2008
    Messages : 62
    Points : 35
    Points
    35

    Par défaut ah la simulation ...

    Bonsoir arzew,

    Je viens de telecharger MPLAB et je viens de telecharger tes fichiers.

    J'ai une probleme concernant le stimulus. Ca ne passe pas !

    Bon, concernant ton pb, j'ai deja eu le cas sous MPLAB et sous Delphi : La simulation est et reste une simulation]. Je n'ait pas verifié ton code, mais si tout tourne (sauf plantage au bout de x secondes), c'est que ton code est bon. Programme ton PIC et chronometre le temps d'allumage d'une led par example (sur un port non utilisé si possible).

    Je reste attentif a tes réponses et vais verifer ton code des demain.

    bon courage

    a+ elecpic

Discussions similaires

  1. Syntax error MPLAB
    Par kira09 dans le forum C
    Réponses: 4
    Dernier message: 18/11/2008, 20h04
  2. Réponses: 4
    Dernier message: 16/02/2008, 16h15
  3. programmation d'un pic18f sous MPlab
    Par nostra76 dans le forum C
    Réponses: 3
    Dernier message: 19/01/2008, 10h52
  4. débutant PB de compilation MPLAB
    Par tiya17 dans le forum Autres
    Réponses: 0
    Dernier message: 24/08/2007, 11h24
  5. Réponses: 3
    Dernier message: 07/03/2007, 17h05

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo