+ Répondre à la discussion
Affichage des résultats 1 à 8 sur 8
  1. #1
    Invité régulier
    Inscrit en
    mai 2009
    Messages
    13
    Détails du profil
    Informations forums :
    Inscription : mai 2009
    Messages : 13
    Points : 7
    Points
    7

    Par défaut Installation avec pyrus.phar pour PHP 5.3

    Bonjour,

    je tente d'installer PEAR, sous Windows, via le fichier pyrus.phar (http://pear2.php.net/pyrus.phar) pour les versions php supérieures à 5.3.1 comme indiqué sur le site http://pear.php.net/manual/fr/instal...troduction.php.

    Lorsque je lance la commande "php pyrus.phar install" voici le message :
    "manifest cannot be larger than 100MB in phar"

    N'étant pas familier de l'extensions phar je ne parviens pas à résoudre ce problème.
    Je préfèrerais un tuto sur pyrus.phar (pas sur go-pear.php) mais à priori ce n'est pas encore très répandu

    Sinon ce sera une installation manuelle des packages...

    Merci !

  2. #2
    Expert Confirmé Sénior

    Inscrit en
    septembre 2010
    Messages
    7 957
    Détails du profil
    Informations forums :
    Inscription : septembre 2010
    Messages : 7 957
    Points : 10 638
    Points
    10 638

    Par défaut

    php pyrus.phar install seul ne fait rien, il faut mettre le nom d'un package derrière

  3. #3
    Invité régulier
    Inscrit en
    mai 2009
    Messages
    13
    Détails du profil
    Informations forums :
    Inscription : mai 2009
    Messages : 13
    Points : 7
    Points
    7

    Par défaut

    idem avec un package "php pyrus.phar install phpDocumentor" le message sur le "manifest" est identique, y compris si le nom du package est erroné.
    100 MB représente combien en "français" ? et pourquoi cette limite ?

  4. #4
    Expert Confirmé Sénior

    Inscrit en
    septembre 2010
    Messages
    7 957
    Détails du profil
    Informations forums :
    Inscription : septembre 2010
    Messages : 7 957
    Points : 10 638
    Points
    10 638

    Par défaut

    il faut installer pyrus avant de pouvoir utilisé... pyrus
    Code :
    php pyrus.phar install -o PEAR2_Pyrus-alpha
    ensuite tu pourras installer les packages normalement

    Code :
    pyrus install phpDocumentor

  5. #5
    Invité régulier
    Inscrit en
    mai 2009
    Messages
    13
    Détails du profil
    Informations forums :
    Inscription : mai 2009
    Messages : 13
    Points : 7
    Points
    7

    Par défaut

    Désolé, toujours le même message.
    J'imagine que la limite des 100MB est bloquante.

  6. #6
    Expert Confirmé Sénior

    Inscrit en
    septembre 2010
    Messages
    7 957
    Détails du profil
    Informations forums :
    Inscription : septembre 2010
    Messages : 7 957
    Points : 10 638
    Points
    10 638

    Par défaut

    Citation Envoyé par jinfo Voir le message
    Désolé, toujours le même message.
    J'imagine que la limite des 100MB est bloquante.
    non c'est lui qui considère que le fichier est trop gros, l'installation de PEAR2_Pyrus-alpha à réussi ? de toute facon c'est toujours en alpha et y'a encore énormément de bug, je te conseil d'attendre que ca sorte vraiment, surtout si c'est pour installer phpdocumentor, pear suffis

  7. #7
    Invité régulier
    Inscrit en
    mai 2009
    Messages
    13
    Détails du profil
    Informations forums :
    Inscription : mai 2009
    Messages : 13
    Points : 7
    Points
    7

    Par défaut

    Je vais suivre ton conseil et attendre que ce soit viable.
    Je vais me contenter de PEAR même si les messages sur les fonctions dépréciées (j'utilise php 5.3.3) ne sont pas engageants avec go-pear.php.

    Merci

  8. #8
    Expert Confirmé Sénior

    Inscrit en
    septembre 2010
    Messages
    7 957
    Détails du profil
    Informations forums :
    Inscription : septembre 2010
    Messages : 7 957
    Points : 10 638
    Points
    10 638

    Par défaut

    Citation Envoyé par jinfo Voir le message
    Je vais suivre ton conseil et attendre que ce soit viable.
    Je vais me contenter de PEAR même si les messages sur les fonctions dépréciées (j'utilise php 5.3.3) ne sont pas engageants avec go-pear.php.

    Merci
    PEAR est pour PHP 4, une fois le gestionnaire installer c'est inutile de télécharger les lib de pear.php.net elles sont toutes obsolètes, je m'en sert plus pour prendre doctrine symfony, le zf et phpunit, et ca permet de mettre tout ca facilement a jour

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •