Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 3 sur 3
  1. #1
    Invité de passage
    Profil pro Eric
    Inscrit en
    janvier 2011
    Messages
    6
    Détails du profil
    Informations personnelles :
    Nom : Eric

    Informations forums :
    Inscription : janvier 2011
    Messages : 6
    Points : 2
    Points
    2

    Par défaut Exécution lente si lancé en Java Web Start

    Je désespère :-(

    J'ai une application qui fonctionne à merveille pour autant qu'elle n'est pas déployée via Java Web Start. En effet dans ce cas la lenteur est désespérante à l'exécution. Je ne parle pas du chargement bien sûr mais bien de l'exécution tout au long du cycle d'utilisation.

    J'utilise massivement la reflexion ainsi que groovy. Est-ce une piste ?

    Si quelqu'un a une idée c'est avec plaisir car mon application doit impérativement être déployée via JWS.

    Par avance merci

  2. #2
    Expert Confirmé Sénior
    Avatar de tchize_
    Homme Profil pro David Delbecq
    Responsable de service informatique
    Inscrit en
    avril 2007
    Messages
    21 764
    Détails du profil
    Informations personnelles :
    Nom : Homme David Delbecq
    Âge : 35
    Localisation : Belgique

    Informations professionnelles :
    Activité : Responsable de service informatique
    Secteur : Service public

    Informations forums :
    Inscription : avril 2007
    Messages : 21 764
    Points : 41 232
    Points
    41 232

    Par défaut

    le problème ne se pose pas lorsque lancée en standalon sur la même machine?


    Affichez la console java webstart pour voir si elle ne se fait pas "flooder" de message type exception, ce serait une piste (génerer une exception prend du temps, de même qu'afficher beaucoup dans la console).

    L'application est-elle signée? Si pas, ça pourrait déclencher des securityException supplémentaire par rapport à la version standalone.
    Tchize (Чиз) faq java, cours java, javadoc. Pensez à et

  3. #3
    Invité de passage
    Profil pro Eric
    Inscrit en
    janvier 2011
    Messages
    6
    Détails du profil
    Informations personnelles :
    Nom : Eric

    Informations forums :
    Inscription : janvier 2011
    Messages : 6
    Points : 2
    Points
    2

    Par défaut Merci

    "le problème ne se pose pas lorsque lancée en standalon sur la même machine?"

    C'est cela. Via JWS elle fonctionne normalement mais très lentement par rapport à la version Standalone.

    L'application est auto signée

    Je vais explorer la piste des exceptions (qui ne se produisent cependant pas en version standalone)

    Merci.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •