p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Invité de passage
    Inscrit en
    janvier 2011
    Messages
    6
    Détails du profil
    Informations forums :
    Inscription : janvier 2011
    Messages : 6
    Points : 2
    Points
    2

    Par défaut Exécution lente si lancé en Java Web Start

    Je désespère :-(

    J'ai une application qui fonctionne à merveille pour autant qu'elle n'est pas déployée via Java Web Start. En effet dans ce cas la lenteur est désespérante à l'exécution. Je ne parle pas du chargement bien sûr mais bien de l'exécution tout au long du cycle d'utilisation.

    J'utilise massivement la reflexion ainsi que groovy. Est-ce une piste ?

    Si quelqu'un a une idée c'est avec plaisir car mon application doit impérativement être déployée via JWS.

    Par avance merci

  2. #2
    Expert Confirmé Sénior
    Avatar de tchize_
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    avril 2007
    Messages
    22 898
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 36
    Localisation : Belgique

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : avril 2007
    Messages : 22 898
    Points : 43 517
    Points
    43 517

    Par défaut

    le problème ne se pose pas lorsque lancée en standalon sur la même machine?


    Affichez la console java webstart pour voir si elle ne se fait pas "flooder" de message type exception, ce serait une piste (génerer une exception prend du temps, de même qu'afficher beaucoup dans la console).

    L'application est-elle signée? Si pas, ça pourrait déclencher des securityException supplémentaire par rapport à la version standalone.
    "Tchize is always good. Tchize is just milk’s attempt at being immortal"
    faq java, cours java, javadoc. Pensez à et

  3. #3
    Invité de passage
    Inscrit en
    janvier 2011
    Messages
    6
    Détails du profil
    Informations forums :
    Inscription : janvier 2011
    Messages : 6
    Points : 2
    Points
    2

    Par défaut Merci

    "le problème ne se pose pas lorsque lancée en standalon sur la même machine?"

    C'est cela. Via JWS elle fonctionne normalement mais très lentement par rapport à la version Standalone.

    L'application est auto signée

    Je vais explorer la piste des exceptions (qui ne se produisent cependant pas en version standalone)

    Merci.

Discussions similaires

  1. questions générales sur Java Web Start
    Par Shiryu44 dans le forum JWS
    Réponses: 12
    Dernier message: 11/04/2005, 15h33
  2. Exception sur Java Web Start
    Par Le Bressan dans le forum JWS
    Réponses: 5
    Dernier message: 01/02/2005, 10h52
  3. [Info]Développement Java Web Start
    Par szdavid dans le forum Interfaces Graphiques en Java
    Réponses: 5
    Dernier message: 26/01/2005, 16h59
  4. java web start qui veut pas se lancer
    Par calvin dans le forum JWS
    Réponses: 4
    Dernier message: 30/06/2004, 11h42
  5. [JNDI] Equivalent avec Java Web Start ?
    Par cameleon2002 dans le forum Java EE
    Réponses: 8
    Dernier message: 18/09/2003, 18h55

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo