Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 10 sur 10
  1. #1
    Invité régulier
    Inscrit en
    avril 2004
    Messages
    80
    Détails du profil
    Informations forums :
    Inscription : avril 2004
    Messages : 80
    Points : 8
    Points
    8

    Par défaut Installation de python sur un OS 64bits

    Bonjour,
    J'ai acheter un nouveau pc, et malheureusement il est en 64bits....
    Au boulot, on fonctionne avec python version 2.5, mais je n'arrive pas à trouver une installation (2.5) pour un OS windows 64bits et processeur intel.
    Merci d'avance
    @+
    julien

  2. #2
    Expert Confirmé
    Avatar de tyrtamos
    Profil pro
    Inscrit en
    décembre 2007
    Messages
    2 241
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2007
    Messages : 2 241
    Points : 3 689
    Points
    3 689

    Par défaut

    Bonjour,

    Si c'est Windows '7' 64 bits, il supporte très bien les logiciels 32 bits, et en ce qui me concerne, Python (2.7) et tout les logiciels liés à Python sont en 32 bits.

    Tyrtamos
    Ne rien ranger permet d'observer la loi universelle d'entropie: l'inévitable convergence vers le chaos...
    Mes recettes python: http://www.jpvweb.com

  3. #3
    Membre confirmé Avatar de Apocalypses
    Homme Profil pro
    Étudiant
    Inscrit en
    novembre 2008
    Messages
    320
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 23
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2008
    Messages : 320
    Points : 247
    Points
    247

    Par défaut

    Bonjour,

    Je ne sais pas si vous avez déja regardé de ce coté, mais voila tout ce qu'il peut y avoir sur un exectubale 64 bits pour python 2.5 :
    http://www.python.org/download/releases/2.5.4/

    For x86 processors: python-2.5.4.msi
    For Win64-Itanium users: python-2.5.4.ia64.msi
    For Win64-AMD64 users: python-2.5.4.amd64.msi
    This installer allows for automated installation and many other new features.
    Dites moi si c'est ce que vous cherchiez...

    Mickael

  4. #4
    Invité régulier
    Inscrit en
    avril 2004
    Messages
    80
    Détails du profil
    Informations forums :
    Inscription : avril 2004
    Messages : 80
    Points : 8
    Points
    8

    Par défaut

    Bonjour,
    Merci pour vos réponses.
    J'ai window 7
    J'ai déjà essayé d'installer des versions 32bits, mais aussi la version IA64bits
    Mais j'ai toujours le même message qui est package non compatible à ce processeur.
    J'ai installer la version 3.2 qui tourne nikel, mais je ne peux bosser avec mes code 2.5
    Si vous avez une idée?
    merci d'avance
    julien

  5. #5
    Membre confirmé Avatar de Apocalypses
    Homme Profil pro
    Étudiant
    Inscrit en
    novembre 2008
    Messages
    320
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 23
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2008
    Messages : 320
    Points : 247
    Points
    247

    Par défaut

    Bonjour,

    Le problème, c'est que quand python 2.5 a été developpé, les ordinateurs 64 bits, ce n'était pas d'actualité, alors à moins qu'il est sortie une version supplémentaire pour s'aligner avec les nouvelles technologies, je ne pense que cela soit possible...

    Bon courage...

    Mickael

  6. #6
    Membre actif
    Inscrit en
    avril 2008
    Messages
    158
    Détails du profil
    Informations forums :
    Inscription : avril 2008
    Messages : 158
    Points : 199
    Points
    199

    Par défaut

    Salut,
    Il me semble que ton code devrait tourner sans problème avec python 2.7, la compatibilité ascendante étant assurée sur la branche 2.x.

  7. #7
    Invité régulier
    Inscrit en
    avril 2004
    Messages
    80
    Détails du profil
    Informations forums :
    Inscription : avril 2004
    Messages : 80
    Points : 8
    Points
    8

    Par défaut

    Merci pour tout vos commentaires, je vais essayer la version 2.7

    J'avais un petit espoir d'une version 2.5 64bits ou compatible.

    Merci encore pour tout !!

  8. #8
    Expert Confirmé Sénior
    Homme Profil pro
    Architecte technique
    Inscrit en
    juin 2008
    Messages
    5 238
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Architecte technique
    Secteur : Industrie

    Informations forums :
    Inscription : juin 2008
    Messages : 5 238
    Points : 7 251
    Points
    7 251

    Par défaut

    Citation Envoyé par astragoth Voir le message
    Merci pour tout vos commentaires, je vais essayer la version 2.7

    J'avais un petit espoir d'une version 2.5 64bits ou compatible.

    Merci encore pour tout !!
    Les binaires de la version Python 2.5 64 bits sont "python-2.5.4.amd64.msi"
    Ce qui ne fonctionne peut être pas c'est le packaging MSI qui est "antérieur" à Windows 7 et qui peut être "pas à jour" pour fonctionner sur cette version.
    La distribution 2.7 32 bits ou 64 bits n'ont pas ces problèmes de compatibilité.
    - W
    Note: Sauf si vous avez de vieux scripts difficiles à requalifier dans les versions récentes, je ne vois pas trop de bonnes raisons à fonctionner avec une version aussi ancienne que 2.5. Pour ce qui est 32/64 bits, si Windows 7 et OSX supportent les deux, les scripts de build des bibliothèques que vous voudrez installer après beaucoup moins.
    Architectures Post-Modernes

  9. #9
    Membre éclairé
    Avatar de Pierre Maurette
    Profil pro Pierre Maurette
    Inscrit en
    juillet 2002
    Messages
    273
    Détails du profil
    Informations personnelles :
    Nom : Pierre Maurette
    Âge : 58

    Informations forums :
    Inscription : juillet 2002
    Messages : 273
    Points : 322
    Points
    322

    Par défaut

    Bonjour,
    Window 7 64bits, Eclipse Pydev et une demi-douzaine de versions de Python. Avec "python-2.5.4.amd64.msi", le code
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    #! /usr/bin/env python
    # -*- coding: utf-8 -*-
     
    import sys, platform
     
    print platform.platform()
    print platform.machine() or 'rien'
    print platform.uname()
    print sys.version
    donne:
    Code :
    1
    2
    3
    4
    Windows-32bit
    rien
    ('Windows', 'SEVEN', '', '32bit', '', '')
    2.5 (r25:51908, Sep 19 2006, 10:05:36) [MSC v.1400 64 bit (AMD64)]
    Avec 2.7 64bits:
    Code :
    1
    2
    3
    4
    Windows-7-6.1.7600
    AMD64
    ('Windows', 'SEVEN', '7', '6.1.7600', 'AMD64', 'AMD64 Family 15 Model 107 Stepping 2, AuthenticAMD')
    2.7 (r27:82525, Jul  4 2010, 07:43:08) [MSC v.1500 64 bit (AMD64)]
    Bon, ça me met le doute. De toute évidence le script sous 2.5 tourne dans le sous-système 32bits. Erreur de ma part (c'est le nom dans Eclipse Python25-64 qui me faisait penser à du 64 bits) ou abus de langage pour python-2.5.4.amd64.msi" qui serait un programme 32bits testé pour tourner sous les Windows 64bits ? Je vérifie et je vous dis quoi.

  10. #10
    Membre éclairé
    Avatar de Pierre Maurette
    Profil pro Pierre Maurette
    Inscrit en
    juillet 2002
    Messages
    273
    Détails du profil
    Informations personnelles :
    Nom : Pierre Maurette
    Âge : 58

    Informations forums :
    Inscription : juillet 2002
    Messages : 273
    Points : 322
    Points
    322

    Par défaut

    Alors, c'était bien "python-2.5.4.amd64.msi" qui était installé. Et l'interprêteur est bien un processus 64bits. C'est donc le module "platform" qui est un peu bancal. Une raisons supplémentaire de préférer une version 2.7, quitte à en installer plusieurs.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •