1. #1
    Invité de passage
    Inscrit en
    janvier 2008
    Messages
    14
    Détails du profil
    Informations forums :
    Inscription : janvier 2008
    Messages : 14
    Points : 1
    Points
    1

    Par défaut [FLASH] XML Caractères spéciaux

    Salut à tous !

    J'ai acheter un Template américain développé en flash.
    Malheureusement j'ai beaux chercher, je n'arrive pas à afficher des caractères spéciaux dans le fichier XML.
    Voici mon script :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
     
    <?xml version="1.0" encoding="UTF-8"?>
    <content>
     
    	<!-- general vars -->
    	<section name="settings">
    		<image imageUrl="_logo.png" />
    		<image imageUrl="_menu_pic4.png" />
    		<image imageUrl="_menu_pic2.png" />
    		<image imageUrl="_menu_pic3.png" />
    		<image imageUrl="_menu_pic1.png" />
    		<image imageUrl="_menu_pic5.png" />
    		<image imageUrl="_menu_pic6.png" />
     
     
    		<item name="textSelectable">true</item>
    		<item name="copyright"><![CDATA[<i>XXXXXX © 2009  |  <font color="#686868"><a href="asfunction:_root.more_click_func, privacyPolicy"> <u>Privacy policy</u></a></font></i>]]></item>
    		<item name="companyName"><![CDATA[<i><font color="#ff8a00"></font></i>]]></item>
    		<item name="slogan"><![CDATA[<i></i>]]></item>
     
    		<item name="menu_splash_title1"><![CDATA[Coupe &#224; facon ]]></item>
    		<item name="menu_splash_title2"><![CDATA[<i>Mod&#233;lisme</i>]]></item>
    		<item name="menu_splash_title3"><![CDATA[<i>Prototypage</i>]]></item>
    		<item name="menu_splash_title4"><![CDATA[<i>Qui somme nous ?</i>]]></item>
    		<item name="menu_splash_title5"><![CDATA[<i>Partage de données</i>]]></item>
    		<item name="menu_splash_title6"><![CDATA[<i>Nous contacter</i>]]></item>
    	</section>
    Les caractères spéciaux ne sont donc pas afficher.

    Merci d'avance
    Sacha

  2. #2
    Modérateur

    Inscrit en
    septembre 2004
    Messages
    10 332
    Détails du profil
    Informations forums :
    Inscription : septembre 2004
    Messages : 10 332
    Points : 17 246
    Points
    17 246

    Par défaut

    Tu pourrais décrire un peu mieux ce que tu as, ce que tu obtiens avec et ce que tu veux. Passons.

    - Je vois que ce fichier annonce qu'il est encodé en UTF-8. Pourtant dans le XML que tu nous montres, le symbole copyright est représenté ©. Ça veut dire que ton éditeur de texte ouvre ce fichier en iso-8859-1 (ou latin-1, ou windows-1252,) alors que ce fichier est en utf-8. Dis à ton éditeur de texte de l'ouvrir en utf-8.

    - Je vois qu'il y a un
    C'est une manière correcte de représenter un é. Si ça ne marche pas, c'est que ton "Template flash" (quoi que ça puisse être) ne sait pas afficher un é.

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo